Subversion on HostMonster (Red Hat 4.1)

I’m finally trying to install Subversion and everything seems to be installing correctly / without error except for the part where I’m supposed to enter the following into the prompt:

./configure -enable-shared -prefix=$HOME

First and foremost, any explanation regarding what this even is (ha) is appreciated but secondly, whenever I submit that command above, the following occurs:


checking whether system uses EBCDIC… no
performing libtool configuration…
./configure: line 8889: syntax error near unexpected token ,' ./configure: line 8889: _LT_DECL(, AS, 0, Assembler program)’

From what little I understand about this, I came to the conclusion that “yum” needed to be installed. So I tried to use wget to get a copy and install it (hoping that it would work with the version(s) of everything I have on my HostMonster account), and from what it seems, it installed correctly as well. So, I then tried to use this “yum” to facilitate the following command:

yum install expat-devel

The reason for this is because I found some synonymous threads created about the same “8889” error above through Google and one suggestion was to use this command to fix the issue as it seemed to fix another person’s issue with this…

Anyway, it didn’t work and I’m basically stuck in the mud here. If anyone is aware of a concise and working tutorial on installing Subversion on HostMonster, I would appreciate a link if possible. I feel like this is getting too hairy for what it’s worth, but I know that acclimating myself to this useful tool is a way to go for long-term goals.

Any help is appreciated.

…and I forgot to include the section of code within “config” that contains the error…

...
esac

test -z "$AS" && AS=as
_LT_DECL(, AS, 0, Assembler program)       <----- [B]THIS IS LINE 8889 (It's weird because it used to be blow...?) Did I cause this?[/B]
tesac

test -z "$AS" && AS=as
_LT_DECL(, AS, 0, Assembler program)     <------- [B]THIS WAS LINE 8889...?[/B]
test -z "$DLLTOOL" && DLLTOOL=dlltool 
_LT_DECL(, DLLTOOL, 0, DLL creation program)
test -z "$OBJDUMP" && OBJDUMP=objdump
_LT_DECL(, OBJDUMP, 0, Object dumper program)


# Check whether --enable-shared or --disable-shared was given.
if test "${enable_shared+set}" = set; then
  enableval="$enable_shared"
 -z "$DLLTOOL" && DLLTOOL=dlltool
...

I had the same problem and was able to get everything compiling by using APR 1.3.12 instead of the latest (1.4.2 as of this post). This was with Subversion 1.6.13.

Note that you will also need to get the sqlite source and copy sqlite3.c to subversion-x.x.x/sqlite-amalgamation before you compile subversion. I got it from http://www.sqlite.org/sqlite-amalgamation-3.6.13.tar.gz.

Hope that helps!

Thanks for the advice, pbrdrinker. I did as you suggested (and modified some steps between points A and B) and I think I have it installed. I have 2 generalized questions that I hope you or someone could possibly lend some input on, though:

1.) It mentioned something about having installed the database outside of SVN. I’m assuming this is going to cause problems… And I never had to use anything pertaining to the SQLite aspect you made mention to. How does the database element work in all this?

2.) I’m currently getting timeouts when trying to access the repository. I’m assuming this has to do with either a port issue or else something failed to install properly. What would you suggest could be the issue at hand with this?

Any insight is appreciated.

  1. You should not have to do any database setup outside of SVN, but you will need a copy of the sqlite source (sqlite3.c) in order to compile the SVN source. You will get compile errors if you don’t copy this file in under subversion-x.x.x/sqlite-amalgamation.

  2. If you’re getting network timeout errors it’s probably because you’re behind a firewall and the port you need to connect via SSH is blocked.

I’d recommend taking a look at:

http://sharpstep.com/Articles/HostMonster-svn/