Stupid vague error with createDate

Here’s the code:

<cfif StructKeyExists(FORM,"currentEmploy_#i#")>
<!--- they're currently employed, so create default 'EMPTY' date --->
     <cfset Employer.dateLeft = CreateDate(1900,1,1)>
     <cfset Employer.dateLeft = CreateDate(ListLast(FORM["empDateLeft_" & i],'/'), ListFirst(FORM["empDateLeft_" & i],'/'), ListGetAt(FORM["empDateLeft_" & i],'2','/'))>

I’ve narrowed it down to the createDate function if the ‘if’ statement returns true. But I don’t see what the problem is. The only type of error explanation I’m getting is “Unrecognized error code: Cannot convert type: com.naryx.tagfusion.cfm.engine.cfStructData : Nested exception message is: java.lang.String”

Doesn’t mean a thing to me though. :frowning:

Anyone see something that I’m not?

nevermind… fixed this. Would be nice though if there was an edit function for the first post.

i guess the lesson to be learned here about editing your posts is: don’t post until you’re sure you won’t need to edit


btw, what was the problem?

To be honest, I don’t know. Monday computer madness? I had it set up like so
<cfset blah = createDate(‘1900’,‘01’,‘01’)> (single quotes aren’t in the original post, but they were there) and it was giving me issues. Tried all sorts of things and then finally put if back like that and it ‘magically’ worked.

My machine apparently wasn’t ready for the weekend to end.