Strange php remote include problem

I have 2 sites hosted in 2 different servers

i am planning to do this in site 1
<?php
require_once(‘http://www.site2.com/file.php’);
?>

allow_url_fopenis on
allow_url_includeis on
in php settings

It was working fine but now that has stopped working and gives blank page

I tried the same code from another server (server 3) and it is working.
I contacted server guys,they say every thing is fine in setting
and now i have no idea what to do.

What should i do.I am confident that it is related to server settings(as same file work in server 3 and even in server 1)
what effects that remote file include?

would be greatful for the help

If you open http://www.site2.com/file.php in your browser, does it contain any output?

yes it opens fine…showing a table

If you load the file using this code, does it display anything?


$file = file_get_contents('http://www.site2.com/file.php');
var_dump($file);

Yes it gives nothing …no error no display either…
even i checked the error log there is nothing…

and i have already said it is working fine in another server.
i can see phpinfo of both server…the functions i have listed above are on
thank you

Strange that’s site2 isn’t returning anything.

Which error log did you check? PHP? Apache? Or both? :slight_smile:

Maybe you could try loading the page from site1 using cURL and sending a User-Agent header along with the request? That might give a better result.

thank you very much for trying to help
The problem was actually cuased by the
php plugin called suhosin

it has been solved now
It seems that if you have that remote file inclusion doesnt work