SSI Dates

I have to do stuff with includes, I cannot tell if I am forgetting something about these guys or the server is wonky.

Under /incl/ i made a footer file with the following:


<p><span class="blueB">E-mail Contact:</span> {link}<br />
	<span class="blueB">Notice:</span> This graphic notice (<img src="/includes/images/icons/icon_exit_disclaimer.gif" alt="You are leaving a CDC Web site." width="10" height="10" />) means that you are leaving our site.<br />
    <span class="blueB">Page last updated:</span> <!--#config timefmt="%B %d, %Y"--><!--#echo var="LAST_MODIFIED"-->
</p>

I uploaded that about 2 weeks ago. I just made edits on a page, but the updated date still is two week ago. I used http://httpd.apache.org/docs/1.3/howto/ssi.html#whenwasthisdocumentmodified

Changing it from .htm to .shtm does nothing.

Thoughts?

I assume you’ve done the obvious like clear the browser; history, cache, etc.

Obviously your server should be SSI enabled for it to work anyway. The only real difference I can see between your version; is there is no white-space before the last two – dashes [on your version] if that matters - which it could do so it’s not considered part of an SSI token.

SSI is enabled, when i do the date command directly into my file it works. Even with the no space, it is ok.
Did the various clears.

It is acting like it reads the date of the include file, then includes it to mine, then prints date. The first and second steps should be swapped.

A bit of research lead me to needing to use the #flastmod directive. But i don’t know how to make the file parameter a variable.

Moved to Server management (report this post if you want it moved somewhere else instead.)

That is fine, i am still banging my head on the wall.