<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8">
    <title>Speech bubble on hovering an image? - #17 by coothead - HTML &amp; CSS - SitePoint Forums | Web Development &amp; Design Community</title>
    <meta name="description" content="How is this done? I have been trying at it to no avail. Seen examples as well, but still not getting it down :frowning: 
.photo {
    position:absolute;
    top:180px;
    left:250px;
    z-index:1;
    width:175px;
    &amp;hellip;">
    <meta name="generator" content="Discourse 2.7.0.beta1 - https://github.com/discourse/discourse version 690f1a257acecdf74f8a08271da0600bc450dd1f">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#3a3a3a">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="SitePoint Forums | Web Development &amp; Design Community Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_3_8ffaa558713d88c774ce57b625b4720c20eb8948.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_b778877d230e841e7bc27f9e6de329cdf6deccb0.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    <!-- Proper Ad Script -->
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/3ea6ceedc3defc7b2344bb8ab6143c942dd5886a.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

  <link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Speech bubble on hovering an image?&#39;" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046.rss" />
    <meta property="og:site_name" content="SitePoint Forums | Web Development &amp; Design Community" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046/17" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046/17" />
<meta property="og:title" content="Speech bubble on hovering an image?" />
<meta name="twitter:title" content="Speech bubble on hovering an image?" />
<meta property="og:description" content="No, it’s positioning is handled here…  .speech:before {     content: url( speech-tail.svg );      position: absolute;     top: 82px; /* svg  top positioning  */     left: 4px; /* svg  left positioning  */     } coothead" />
<meta name="twitter:description" content="No, it’s positioning is handled here…  .speech:before {     content: url( speech-tail.svg );      position: absolute;     top: 82px; /* svg  top positioning  */     left: 4px; /* svg  left positioning  */     } coothead" />
<meta property="article:published_time" content="2021-01-24T00:39:55+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/9d87c81079e84b2d9c7516aa076acf66e0f80774.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="SitePoint Forums | Web Development &amp; Design Community" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/speech-bubble-on-hovering-an-image/363046">Speech bubble on hovering an image?</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/html-css/25" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #ba5401'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>HTML &amp; CSS</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T17:48:56Z' class='post-time'>
                January 23, 2021,  5:48pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T17:48:56Z'>
          <span itemprop='position'>#5</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/coothead">@coothead</a> I can’t get a smooth transition on hover, no matter which tag I apply it to in the CSS <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/flushed.png?v=9" title=":flushed:" class="emoji" alt=":flushed:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T18:02:25Z' class='post-time'>
                January 23, 2021,  6:02pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T18:02:25Z'>
          <span itemprop='position'>#6</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="ladans37" data-post="5" data-topic="363046">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/ladans37/40/89361_2.png" class="avatar"> ladans37:</div>
<blockquote>
<p>I can’t get a smooth transition on hover,</p>
</blockquote>
</aside>
<p>That’s because ‘display:none’ to ‘display:block’ is,<br>
like a light switch, an instantaneous event. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/6/c/6c3193d1dd46244da3c8c6f719c9f5e2abdd5ae8.gif?v=9" title=":biggrin:" class="emoji emoji-custom" alt=":biggrin:"></p>
<p>Try using ‘opacity:0’ to ‘opacity:1’ instead as it’s<br>
working is more akin to a dimmer switch. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02a1faf5c304c9786b0783439531204d9d204d04.gif?v=9" title=":winky:" class="emoji emoji-custom" alt=":winky:"></p>
<p><span class="bbcode-i">coothead</span></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T18:04:35Z' class='post-time'>
                January 23, 2021,  6:04pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T18:04:35Z'>
          <span itemprop='position'>#7</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"> so instead of display:none, do… opacity:0 ? <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T18:05:57Z' class='post-time'>
                January 23, 2021,  6:05pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T18:05:57Z'>
          <span itemprop='position'>#8</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Yepper that worked <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/smiley.png?v=9" title=":smiley:" class="emoji" alt=":smiley:">. Yippeee! <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/heart_eyes.png?v=9" title=":heart_eyes:" class="emoji" alt=":heart_eyes:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T18:13:00Z' class='post-time'>
                January 23, 2021,  6:13pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T18:13:00Z'>
          <span itemprop='position'>#9</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Gosh, I’ve actually brought a little happiness into you life at last.  <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/5/f/5f6daf7fe1bb1446f28998770f13f84c9fc95e7c.gif?v=9" title=":rofl:" class="emoji emoji-custom" alt=":rofl:"></p>
<p><span class="bbcode-i">coothead</span></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T18:14:20Z' class='post-time'>
                January 23, 2021,  6:14pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T18:14:20Z'>
          <span itemprop='position'>#10</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/joy.png?v=9" title=":joy:" class="emoji" alt=":joy:"> <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/joy.png?v=9" title=":joy:" class="emoji" alt=":joy:"> <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/joy.png?v=9" title=":joy:" class="emoji" alt=":joy:"> - It’s all good, you always bring happiness to me. And I’m sure to everyone here <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/smiley.png?v=9" title=":smiley:" class="emoji" alt=":smiley:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T18:21:59Z' class='post-time'>
                January 23, 2021,  6:21pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T18:21:59Z'>
          <span itemprop='position'>#11</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group quote-modified" data-username="ladans37" data-post="10" data-topic="363046">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/ladans37/40/89361_2.png" class="avatar"> ladans37:</div>
<blockquote>
<p>…you always bring happiness…</p>
</blockquote>
</aside>
<p>Oh, if that were only true. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/4/84125cb3a26d4aa5fe6af0018729905ef73bd73c.gif?v=9" title=":wonky:" class="emoji emoji-custom" alt=":wonky:"></p>
<p>I quite often get sent to “Naughty Mat” for my postal efforts. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/2/4/24234138fbdbf99d4fe7067295ed6df5d4252370.gif?v=9" title=":taped:" class="emoji emoji-custom" alt=":taped:"></p>
<p><span class="bbcode-i">coothead</span></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T18:23:58Z' class='post-time'>
                January 23, 2021,  6:23pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T18:23:58Z'>
          <span itemprop='position'>#12</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Why lol. Time for lunch, talk to ya later <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/smiley.png?v=9" title=":smiley:" class="emoji" alt=":smiley:"> <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/hamburger.png?v=9" title=":hamburger:" class="emoji" alt=":hamburger:"> <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/fries.png?v=9" title=":fries:" class="emoji" alt=":fries:"> <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/pizza.png?v=9" title=":pizza:" class="emoji" alt=":pizza:"> <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/bread.png?v=9" title=":bread:" class="emoji" alt=":bread:"> <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/poultry_leg.png?v=9" title=":poultry_leg:" class="emoji" alt=":poultry_leg:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-23T21:47:29Z' class='post-time'>
                January 23, 2021,  9:47pm
              </time>
              <meta itemprop='dateModified' content='2021-01-23T21:47:29Z'>
          <span itemprop='position'>#13</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>How do I put the green tail appear on both sides of the white one? It’s showing one side right now.</p>
<p><iframe id="cp_embed_RwGmqwJ" src="https://codepen.io/cpUserpen/embed/preview/RwGmqwJ?height=300&amp;slug-hash=RwGmqwJ&amp;default-tabs=css,result&amp;host=https://codepen.io" title="My Tooltip Example 2" scrolling="no" frameborder="0" height="260" class="cp_embed_iframe" width="695" seamless="seamless" sandbox="allow-same-origin allow-scripts allow-forms allow-popups allow-popups-to-escape-sandbox allow-presentation"></iframe></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-01-24T00:28:57Z'>
              <time itemprop='dateModified' datetime='2021-01-24T00:29:35Z' class='post-time'>
                January 24, 2021, 12:29am
              </time>
          <span itemprop='position'>#14</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi there landans37,</p>
<p>I would use an svg instead…</p>
<p><a class="attachment" href="/community/uploads/short-url/9GG56zftxH1I3QNdOCWiygqq9SD.zip">speech-tail.svg.zip</a> (312 Bytes)</p>
<p>…with this code…</p>
<pre><code class="lang-auto">&lt;!DOCTYPE HTML&gt;
&lt;html lang="en"&gt;
&lt;head&gt;

&lt;meta charset="utf-8"&gt;
&lt;meta name="viewport" content="width=device-width,height=device-height,initial-scale=1"&gt;

&lt;title&gt;Untitled document&lt;/title&gt;

&lt;!--
The internal CSS should be transferred to an external file
&lt;link rel="stylesheet" href="screen.css" media="screen"&gt;
--&gt;

&lt;style media="screen"&gt;
body {
    background-color: #808080;
  } 
.myDiv {
 	position: relative;
    top: 180px;
    left: 250px;
 }
.myDiv a, .photo{
 	display: block;
    width: 175px;
    height: 175px;
    border-radius: 50%;
    overflow: hidden;	
 }
 
 .speech {
    position: absolute;
    left: 180px;
    top: -110px;
    width: 200px;
    height: 100px;
    text-align: center;
    line-height: 100px;
    background-color: #fff;
    border: 4px solid green;
    border-radius: 30px;
    box-shadow: 2px 2px 4px #222;
    font-family: arial, 'open Sans', 'segoe ui';
    font-size: 20px;
    color: #000; 
    opacity: 0;
    transition: 0.4s ease-in-out; /* Animation */
 }

.speech:before {
    content: url( speech-tail.svg ); 
    position: absolute;
    top: 82px;
    left: 4px;   
  }
.myDiv a:hover + .speech {
     opacity: 1;
 }
&lt;/style&gt;

&lt;/head&gt;
&lt;body&gt;

 &lt;div class="myDiv"&gt;
  &lt;a href="https://imgbb.com/"&gt;
   &lt;img class="photo" src="https://i.ibb.co/q0C4D4M/58461451-594363321051717-6049779766507077632-n.jpg" 
   alt="young lady with pink cheeks and ribbons in her hair"&gt;
  &lt;/a&gt;
  &lt;div class="speech"&gt;Hey!&lt;/div&gt;
 &lt;/div&gt;

&lt;/body&gt;
&lt;/html&gt;</code></pre>
<p>The svg file needs to linked to here…</p>
<pre><code class="lang-auto">.speech:before {
    content: url( speech-tail.svg ); 
    position: absolute;
    top: 82px;</code></pre>
<p><span class="bbcode-b">Note</span>:-<br>
I was going to change all those awful <span class="bbcode-b">px</span> units to <span class="bbcode-b">em</span>.<br>
but didn’t bother in the end as I knew that you would<br>
change them all back.</p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T00:30:38Z' class='post-time'>
                January 24, 2021, 12:30am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T00:30:38Z'>
          <span itemprop='position'>#15</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi. Ok cool, I can use svg’s. I’ll take a look. Thanks <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T00:34:55Z' class='post-time'>
                January 24, 2021, 12:34am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T00:34:55Z'>
          <span itemprop='position'>#16</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>This looks great. I’ll need to give the svg a class name I guess to be able to move it to the desired position. Color and stuff too, though I see that done through the html end <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T00:39:55Z' class='post-time'>
                January 24, 2021, 12:39am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T00:39:55Z'>
          <span itemprop='position'>#17</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="ladans37" data-post="16" data-topic="363046">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/ladans37/40/89361_2.png" class="avatar"> ladans37:</div>
<blockquote>
<p>I’ll need to give the svg a class name</p>
</blockquote>
</aside>
<p>No, it’s positioning is handled here…</p>
<pre><code class="lang-auto">.speech:before {
    content: url( speech-tail.svg ); 
    position: absolute;
    top: 82px; /* svg  top positioning  */
    left: 4px; /* svg  left positioning  */  
  }</code></pre>
<p><span class="bbcode-i">coothead</span></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T00:40:57Z' class='post-time'>
                January 24, 2021, 12:40am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T00:40:57Z'>
          <span itemprop='position'>#18</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Oh… hm, didn’t see that lol. I’ll check it out <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/smiley.png?v=9" title=":smiley:" class="emoji" alt=":smiley:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T00:45:34Z' class='post-time'>
                January 24, 2021, 12:45am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T00:45:34Z'>
          <span itemprop='position'>#19</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <blockquote>
<p>The svg file needs to linked to here…</p>
</blockquote>
<p>Stuck with this one. Only way can do is upload it to imgbb and use its url instead… other than that, I’m so bad with linking it locally <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/weary.png?v=9" title=":weary:" class="emoji" alt=":weary:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-01-24T00:55:58Z'>
              <time itemprop='dateModified' datetime='2021-01-24T00:59:08Z' class='post-time'>
                January 24, 2021, 12:59am
              </time>
          <span itemprop='position'>#20</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="ladans37" data-post="19" data-topic="363046">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/ladans37/40/89361_2.png" class="avatar"> ladans37:</div>
<blockquote>
<p>Stuck with this one.</p>
</blockquote>
</aside>
<p>Put the svg in the same place as your image of the<br>
<span class="bbcode-i">“young lady with pink cheeks and ribbons in her hair”</span></p>
<p><a href="https://i.ibb.co/" data-bbcode="true">https://i.ibb.co/</a></p>
<p>It would then be …</p>
<p><code> 
content: url( https://i.ibb.co/speech-tail.svg ); </code></p>
<p><span class="bbcode-i">coothead</span></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T00:57:07Z' class='post-time'>
                January 24, 2021, 12:57am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T00:57:07Z'>
          <span itemprop='position'>#21</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Ok done.</p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T00:58:46Z' class='post-time'>
                January 24, 2021, 12:58am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T00:58:46Z'>
          <span itemprop='position'>#22</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Looks like this now:</p>
<p>content: url(‘My Received Files/speech-tail.svg/speech-tail.svg’);</p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T01:09:31Z' class='post-time'>
                January 24, 2021,  1:09am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T01:09:31Z'>
          <span itemprop='position'>#23</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I assumed that  it would be …</p>
<pre><code class="lang-auto">content: url( https://i.ibb.co/speech-tail.svg );</code></pre>
<p>Unfortunately, <a href="https://i.ibb.co/" data-bbcode="true">https://i.ibb.co/</a> gives this information…</p>
<aside class="quote no-group">
<blockquote>
<p>Some files couldn’t be added</p>
<pre><code>speech-tail.svg - Invalid or unsupported file format.
</code></pre>
</blockquote>
</aside>
<p>So that is a problem only  you can resolve.</p>
<p><span class="bbcode-i">coothead</span></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ladans37'><span itemprop='name'>ladans37</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/speech-bubble-on-hovering-an-image/363046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-01-24T01:10:55Z' class='post-time'>
                January 24, 2021,  1:10am
              </time>
              <meta itemprop='dateModified' content='2021-01-24T01:10:55Z'>
          <span itemprop='position'>#24</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Ok sure. I’ll go that route then. Thanks <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
        </div>

        <meta itemprop='headline' content='Speech bubble on hovering an image?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <!-- BSA Ad Script -->
<!--
<script>
    (function(){
        var bsaScript = document.createElement('script');
        bsaScript.type = 'text/javascript';
        bsaScript.async = true;
        bsaScript.src =  "https://cdn-s2s.buysellads.net/pub/sitepoint.js?" + (new Date() - (new Date() % 600000));
        document.getElementsByTagName('head')[0].appendChild(bsaScript);
    })();
</script>
-->
<!-- Proper -->
<!--
<div id="footer-ad-spacer"></div>
<div id="footer-ad" class="proper-ad-unit ad-sticky">
    <div id="proper-ad-sitepoint_main_1">
        <script> 
            propertag && propertag.cmd.push(function() { proper_display('sitepoint_main_1'); });
        </script>
    </div>
</div>
-->
  </body>
  
</html>
