Soap Problems

Hi,

I’m really stuck doing a soap request.

I can do basic soap calls, but a service I require needs me to put login details within the soap header.

Can some please help me with this?

This is the soap request I need to send:


POST /vrm.asmx HTTP/1.1
Host: www.vrm.etgws.co.uk
Content-Type: text/xml; charset=utf-8
Content-Length: length
SOAPAction: "EurotaxGlass's/WebService/VehicleLookup/VRM/Search"

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
  <soap:Header>
    <SecuritySoapHeader xmlns="EurotaxGlass's/WebService/VehicleLookup/VRM">
      <ClientCode>string</ClientCode>
      <AccountName>string</AccountName>
      <Password>string</Password>
      <Success>boolean</Success>
      <Denial>string</Denial>
    </SecuritySoapHeader>
  </soap:Header>
  <soap:Body>
    <Search xmlns="EurotaxGlass's/WebService/VehicleLookup/VRM">
      <VehicleRegistration>string</VehicleRegistration>
    </Search>
  </soap:Body>
</soap:Envelope>

I have tried PHPs built in soap functions but I still can not get it to work.

I was reading that php’s built in soap functions have a bug when doing soap requests .net servers. could this be the problem?

What about using curl?

What did you try?

its ok i solved it using curl.

If you done with cURL kindly let me know how you did it. I am also stuck with SOAP and facing same issue as you were facing. Kindly Help me.

Waiting for your positive reply.

Thanks in advance :slight_smile: