Session ID being reset at each visit

I am having an issue with the session id cookie being set anew at each request to my PHP application. This happens with both Firefox and IE.

The application merely calls session_start(), it also runs isset on a session variable (not being set in this case), that’s all as far as sessions go.

My PHP session settings are as follows

Session Support enabled
Registered save handlers files user
Registered serializer handlers php php_binary wddx

Directive Local Value Master Value
session.auto_start Off Off
session.bug_compat_42 On On
session.bug_compat_warn On On
session.cache_expire 30 30
session.cache_limiter nocache nocache
session.cookie_domain no value no value
session.cookie_httponly Off Off
session.cookie_lifetime 0 0
session.cookie_path / /
session.cookie_secure On On
session.entropy_file no value no value
session.entropy_length 0 0
session.gc_divisor 1000 1000
session.gc_maxlifetime 1440 1440
session.gc_probability 1 1
session.hash_bits_per_character 5 5
session.hash_function 0 0 PHPSESSID PHPSESSID
session.referer_check no value no value
session.save_handler files files
session.save_path no value no value
session.serialize_handler php php
session.use_cookies On On
session.use_only_cookies On On
session.use_trans_sid 0 0

I can think of three reasons for this; either the session is not stored between visits, or the cookie is not kept by the client, or it is simply ignored.

It is most definitely not the second of these, if I create session ids with different names they accumulate at the client.

Any ideas?

PHP is running as an Apache module.

It was solved by removing the stored cookies, with the different session names that had been used, and reloading the page.

I need to bump this thread, for it seems that the reason the session stopped being reset was not clearing cookies, but using an SSL connection.

That is, the sessions are still reset at every visit with an ordinary http connection, but for some reason they are retained when using https. At least I can keep testing and developing my application, but this needs to be solved eventually.

Ideas for what can be causing this are therefore again welcomed, maybe it is something about the implementation of SSL protocols that I am overlooking?

I seem to be posting a bit of unwarranted posts lately, should do more debugging.

It was a matter of setting