SEO friendly URLs gets converted to the php long form automatically

I’m guessing this is an Apache configuration issue, but not sure…

I am using mod_rewrite to create SEO-friendly URLs. I noticed that on some servers, the SEO-friendly URL will get automatically converted to the long form equivalent (e.g. domain.com/file.php?a=z&b=y).

Do you know to resolve this issue?

Please let me know if further clarification is needed. Thanks.

On the server with the long URLs, is mod_rewrite enabled on the server?

What other differences are there between the servers?

Yea, mod_rewrite is enabled. It’s actually loading up the correct page/content. The difference is that the URL in the address bar is converted to the long URL.

Is there an easy way for me to compare differences between servers? Can I run something like phpinfo(), but for Apache?