Safari ignoring body

Hi Guys,

just wondering if anyone has ever had a problem where safari ignored the body element in css?

my website works on ie6,7,8, ff, chrome but on safari it ignores the body tag so my background image doesnt show and its not using the font i specified in body element

the only way i have found of making it work is to repeat the body element twice in my css

but this is not good practice right?

anyone know any other workaround?

it was safari in widnows, i figured it out

was this line at the top of the css

@charset “utf-8”;

for some reasont hat was causing safari to ignore the body element on my css stylesheet :S

i removed that and it works fine:shifty:

You’ll have to post code, because no, Safari doesn’t have any obvious known bug (that I know of) that makes it ignore the body styling completely… however, I have seen instances where Safari was picky in how you do things like set overflow on the body.

A link would be even better. Is this only Safari on Mac or also Safari on Windows?

Dreambeaver adds a lot of things it shouldn’t… it also starts all your new documents with a Transitional doctype (you should start new documents with Strict), along with all the other things…

…unless you change the settings.

If the charset isn’t the first character in the stylesheet, then Webkit will ignore the first CSS rule in the sheet. It’s a documented bug.

I never, ever state the charset in my css sheet. While I save absolutely everything as UTF-8, CSS must be written in plain old ASCII. One should never need to state a charset for CSS.

Thanks for the bug tip, Ryan!

its auto added into a css document when you create a new one in dreamweaver :x