Safari capitalizing a cookie

So I have the weirdest bug.
I can’t for the life of me figure out why it does this and it didn’t before (I’ve added some pages to the site and changed some code but didn’t even touch my cookie code).

I have a couple of cookies that i specify in the same document in a few rows after each other


$cookieTime = time()+60*60*24*30;

setcookie("ingelogd",true,$cookieTime);
setcookie("gebruiker",$gebruiker,$cookieTime);
setcookie("secure",$secure,$cookieTime);
setcookie("id",$id,$cookieTime);

This is the ONLY place where I set cookies, apart from the place where I unset them.

Safari automatically calls my secure cookie Secure instead, resulting in the browser not reading the cookie and ruining the site.

Now that I’m at home I realize I should have tried naming the cookie differently but for some reason I didn’t come up with that and I don’t have access to Safari here. But maybe somebody knows why it is doing this.

Ofc I tried deleting all my cookies etc starting over clean but it just keeps capitalizing it (and none of the other cookies!).

PS: I don’t touch the cookies apart from reading them.

Insanely late reaction because I was on vacation, that did seem to be the case.
I tried it out at home as well and that fixed it, strange strange safari.

I’d change the name of the cookie. It might be that Secure is a reserved word and is making Safari act weird.

Noem hem anders gewoon ‘veilig’ of zo :wink:

Edit>>
I can confirm this, setting a cookie with name ‘secure’ capitalises it.
This makes me dislike Apple even more :slight_smile: