Roundcube Error due to Php

We have installed Roundcube to be our new Web based email.
However we are getting these Php related Errors when trying to use some of its features:

PHP Error: Enigma plugin: Option ‘enigma_pgp_homedir’ not specified in /var/www/html/roundcube/plugins/enigma/lib/enigma_engine.php on line 91
(GET /rcube/?_task=settings&_action=edit-identity&_iid=5&_framed=1)

Do you know how to fix this?


This link may be of interest:

Actually I read that page multiple time. But it provides NO real answer to this question at all

Or do you see an answer to this problem there that I am missing it!


Well, the OP in that thread seemed to have their enigma_pgp_homedir set to null (see their final post):

What is your enigma_pgp_homedir set to?

Hello James,

How do we fund out What our enigma_pgp_homedir set to?

And I do not quite understand how this cat command works?



You should just be able to type that command into the terminal and have it spit out the appropriate config option.

All that the cat command does is concatenate files and print them to the standard output. The pipe (|) feeds the result of the cat command to the grep command, that will then search for the appropriate config option (i.e. the string you pass it).

You’ll likely need to adjust the path to the config file, as it contains the version you are running (so if that’s not v1.2.3 you’ll need to alter it).

Alternatively, you could just open that file in a text editor and look for the entry manually.


I found the file
under dir: /var/www/html/roundcube/plugins/enigma

and see that: $config[‘enigma_pgp_homedir’] is already = null;

So nothing to change there!
FYI, i changed the and restarted Apache, and still same Error:


Error No. [600]


I don’t think it’s meant to be null.

Well what should it be then?
I thought as per solution you suggested, you stated it should be null. That is:

cat /opt/www/roundcubemail-1.2.3/plugins/enigma/ | grep enigma_pgp_homedir
$config[‘enigma_pgp_homedir’] = null;

Anyway, what should be if not null as it is now?
And why was this file had file type of:
rather than


No idea. Your original question was:

And my understanding of the thread that John posted was that the OP found the value of enigma_pgp_homedir to be null and changed it to the correct value, thus solving their problem.

I don’t run Roundcube, so I’m not sure how much help I can be and am going to bow out. Good luck :slight_smile:


This is an old standard of application installations and once very popular.

Files with a .dist extension were usually in an installation directory and meant to be copied without the extension. The files could then be processed by the PHP interpreter.

Usually there is a lot of information and examples regarding different scenarios.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.