Root domain e.g does not work but works?

Hello Guys,
I just setup a few website on a new windows dedicated server. Without using a cpanel.

However after adding the host names the root does not work.

Only if I add the www

In the glue records of the DNS, I had added * and left it blank e.g. ( these are also present in the host names of the IIS administration)

what am I doing wrong here ?


You need to access your DNS daemon and add the non-www’d version of your domain name. Much easier done with cPanel, though, especially as it would depend upon the DNS daemon you’re using.



thanks for your reply.

I dont know why this thread was moved to apache, as I posted it in domain names and am using windows 2008 and not a cpanel.

I ran a check on and got this error and trying to figure how to fix

TLD Parent Check

WARNING: Looks like the parent servers do not have information for your TLD when asked. This is ok but can be confusing

Missing nameservers reported by parent

FAIL: The following nameservers are listed at your nameservers as nameservers for your domain, but are not listed at the parent nameservers (see RFC2181 5.4.1). You need to make sure that these nameservers are working.If they are not working ok, you may have problems!

Off Topic:

This is also a more general “Server Configuration” forum. :slight_smile:

I found the solution to this.

Basically we were not using a cpanel and setting up our DNS ourselves, so I added a blank dns to the root domain name and it worked.