[ Resolved ] - Linux Mint 19.3 Tricia odd effect - [ corrupted tooltips ]

I would be tempted to use Windows and wait for an update which should be soon if others are experiencing the same problem. This is a problem when using cutting edge systems. Perhaps stay with tried and tested older versions.

Did you try other forums?

Also use gpart to create a 50Gb partition and install Ubuntu. There should be nearly 150Gb still available, enough for even other Linux systems.

At the end of the day each operating system is just a glorified menu system to run your own programs :slight_smile:

Hi there John,

although it will be a pain in in the arse,
I am going to try a clean install of “Mint”
again. :wonky:

The reason for this is that I am using the
USB flash drive as I type this post to you
and the tests that I have made do not show
the oddity. any more.

I will report back in due course - ( probably
about 24 hours at the pace that I work ) - with
the results. :rolleyes:

coothead

Strange the problem is not showing on the USB, I did think it would be software and to wait for an update.

Best of luck and don’t forget to use gpart for other systems.

It is possible to use multiple systems and share the same data which I have read about but never tried. Currently I use the online host server as a data backup.

Edit:

What will you do if the clean install has the same problem? :slight_smile: :frowning:

I will smile benignly. :winky:

coothead

2 Likes

Hi there peeps,

after about twenty hours of concerted effort I now
have "Linux Mint 19.3 Tricia " working without any
traces of the aggravating oddity. :winky:

Please do not ask me what I actually did though. :taped:

All I can say, is that I made quite a few installation
attempts and SSD tinkerings without exactly any
real idea of what I was doing. The final install was
achieved when I placed three partitions on the SSD
in a similar fashion to my “Windows 7” SSD and
then I probably just got lucky with the installation
choices that I then made. :rofl:

I will, of course, be keeping my fingers crossed when
I fire up the old pc tomorrow morning with the hope
that the Computer does not say no. :unhappy:

coothead

3 Likes

Hi Coothead,

I’m delighted you eventually managed to restore your system and never reverted back to Windows.

I was surprised at how long it took considering a USB install takes about twenty minutes?

It is an fortunate fact that the hardware is gradually growing old and software progressing at an alarming rate. The fragile link between the two will no doubt stretch to breaking point again…

Embrace the inevitable! :slight_smile:

To minimise the re-install process I created an update folder, populated with links, passwords, etc and copied to both another hard-drive partition and the online server. This folder size is increasing due to LAMP, SQL data, other software, libraries, Github source, composer, etc.

I am curious to learn reduction techniques for this annoying and wasted time spent to get back to square one… reminds me of where would you like to go today…

image

1 Like

This is a good idea. I, too, have a set of notes on my latest hardware/software setup. Thanks to that and a comprehensive backup policy, reinstalling and re-configuring my system from scratch takes a couple of hours.

Hi there John,

well that was short lived. :wonky:

I am now smiling benignly. :innocent:

its-back

coothead

Man, that sucks!

Is it possible for you to swap the graphics card out for something else?

I would hazard a guess and think it is due to a browser CSS conflict.

Have you tried Opera, Brave, Chrome, etc?

Nah man. Look at post 4 in this thread. It’s happening in his file explorer, too.

I’m no expert in such matters, but I find a hardware/driver issue to be much more likely.

I think it is a software problem because of this post #22

The reason for this is that I am using the
USB flash drive as I type this post to you
and the tests that I have made do not show
the oddity. any more.

… Although the oddity could be intermittent :frowning:

Then the question would be what is different between the live USB version and the fully installed on disk version.

Software :slight_smile:

It’s a feature…

The live USB might some rudementary generic graphics driver that works but isn’t very performant, but when installing it decides the system could do with a more specific and more performant driver. Which in this case doesn’t work out too well.

FWIW, the effect is called “tearing”, maybe that helps googling for answers?

Tooltips are rendered by the OS, not by the browser. CSS has nothing to do with it :slightly_smiling_face:

3 Likes

thank you all for your replies and suggestions. :winky:

The observation by @rpkamp would seem to throw
a light on the problem.

I have reinstalled Linux Mint for the umpteenth time
but have not installed any updates this last time.
Two days have elapsed and the oddity has not
reappeared.

I have no idea which of the 68 updates displayed by
the “Update Manager” is the cause of the problem.

This, of course, is not an ideal situation.

The Installation will be worse than useless without
the ability to update.

I will now test out “Ubunto” on another SSD to see if
it is beset with the same problem.

Perhaps, as @John_Betong suggested, I should
just bite the bullet, and post this problem on the
“Linux Mint” forums.

coothead

I think it could be interesting if the tooltip display could be affected by the system font that is used.

Could you test changing system font in the Appearence tool and also the Qt-Configuration Interface ToolBox settings if you have it?

If you have the time o/c, and feel it could be worth to explore. :slightly_smiling_face:

Hi there peeps,

I have, at last, found the solution to the oddity…

Terminal:-

    sudo apt install xserver-xorg xserver-xorg-video-all

Restart computer

Source:-

Corrupted/distorted tooltips after latest update

As a matter of interest, I found that “Ubunto”
had the same problem.

coothead

5 Likes

As we say in Dutch: de aanhouder wint. Loosely translates to: he who perseveres, wins :slightly_smiling_face:

Good on you for fixing it and thanks for sharing your solution. Those who end up here with the same issue will be grateful :slightly_smiling_face:

4 Likes