[ Resolved ] - I have messed up Linux Mint Update Manager

Hi there peeps,

being a bald headed old fart I have managed to
mess up the Linux Mint Update Manager. :eyebrows:

This problem was caused when I installed the Tor
Browser and then uninstalled it with this line…

sudo apt-get purge tor polipo

…which I found here…

How do I completely uninstall tor?

Apart from thrashing my derriere is there any other
way to correct my gross stupidity?

coothead

So how this reads to me:
TOR has uninstalled itself, including its Repo Key. What it hasnt done is remove itself from your software sources list. So your update program tries to query all of its repos, and finds it cant talk to the torproject.org repo anymore, so it dies a horrible death.

Check your Software Sources (it should be in your menu) and remove the TorProject repo from them?
EDIT: Or, if you still need to get packages from the TorProject repo, go and get the PPA key for that repo again.

1 Like

Try this command:

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

From: https://forums.linuxmint.com/viewtopic.php?t=74444

1 Like

Hi there @m_hutley and @Chronzam,

thank you kindly for your suggestions. :winky:

Whilst waiting for a reply here further searches
uncovered a solution to my problem…

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 74A941BA219EC810

Source:-

coothead

1 Like

Basically, you’ve told your machine “No go get the key for the TOR Repo again” :wink:

1 Like

Hi there m_hutley,

I think that I can just about live with that. :winky:

coothead

Could not refresh the list of updates

Without going into the causes for this “stand still” situation, I suggest you could try this quick fix to get the Update Manager working again:

(Pardon the Windows user approach to describe the solution.)

  1. Launch the Synaptic Package Manager* from the menu. (Or “synaptic-pkexec” in the terminal)

  2. Choose the “Installed (upgradable)” view in the left pane. (Could also be sorted in top by the “Status” icon in the package pane.)

  3. In the package list the [!] packages are now shown. Select all of them and choose “Force Version…” in the menu > Package dropdown. (Ctrl+e)

  4. In the dialog, keep the top option in the select, and press the “Force Version” button.

  5. Go to the menu > Edit dropdown and press “Apply Changes”. (Ctrl+p)

  6. Accept and continue the install.

  7. Launch the Upgrade Manager (“mint-upgrade” in the terminal) and enjoy it’s all working again. :cowboy_hat_face:

Edit)
Seems you got it sorted now, happy to hear! :slightly_smiling_face:

You could save the above general quick fix for the next time this happen (and it will). :wink:

1 Like

Hi there Eric_J,

thanks for that suggestion, I will save it for future disasters. :winky:

I thought that i would test the procedure but came unstuck at #3. :wonky:

  1. Select all of them and choose “Force Version…” in the menu

I can only select them individually, not in bulk.

Is that what you meant?

coothead

:wink:

The common methods works:

  • To select all items:
    Ctrl+a.

  • To select all in between a two:
    Select the first item (with mouse or Space key) then keep the Shift key pressed while selecting (or arrow key to and space) the last item.

  • To add to the current selection:
    Keep the Ctrl key pressed while selecting (or arrow key to and space) additional items.

  • To subtract from the current selection:
    Keep the Ctrl key pressed while deselecting (or arrow key to and space) individual items.

1 Like

Hi there Eric_J,

OK that works. :winky:

I notice that #4 “Force Version” gives me this slightly disturbing information…

The package manager always selects the most applicable version available.
If you force a different version from the default one, errors in the dependency
handling can occur.

Should I be concerned?

coothead

As in step 6. Accept and continue the install.

But if you check the versions for each item itself there will be different versions for each one. The packet manager will pick the applicable latest for each and force that.

Then the it will write a new current list of updates for the Update Manager.

I can’t remember if the “could not refresh the list” error was ever experienced when updating through the package manager. Maybe it’s a shortcoming in the Mint Update Manager if it can’t handle packages marked upgradable in the package manager.

Mind though, I’m really not sure this quick fix would have fixed your original issue. It’s what I usually first try when the Upgrade Manager throws an error like that. :slightly_smiling_face:

1 Like

Hi there Erik_J,

thanks for the clarification. :winky:

coothead

1 Like

wow so how is it now ? did u solve it ?

  1. It fine now. :winky:
  2. Post #4 shows how I solved it. :winky:
  3. @m_hutley, @Chronzam, and @Erik_J
    provided other possible solutions which I
    will test next time I happen to mess up!! :biggrin:

coothead

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.