<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>Removing addRandom and arrays from the multiplayer code - #21 by asasass - JavaScript - SitePoint Forums | Web Development &amp; Design Community</title>
    <meta name="description" content="I started off with this code: 
https://jsfiddle.net/toyk5d7p/ 
Removing addRandom and arrays I am left with this: 
I know that everything works in the code. 
It looks right to me. 
https://jsfiddle.net/orydf57j/ 
Did I d&amp;hellip;">
    <meta name="generator" content="Discourse 2.8.0.beta4 - https://github.com/discourse/discourse version 189b4c49928cc90b929a23bcf6111f1054c2944f">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#3a3a3a">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="SitePoint Forums | Web Development &amp; Design Community Search">

      <link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_7fad8de69f86396b5428abccaf383230e17fd9bc.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop"  />
      <link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_521_57783566528e9ffb2adec0bd8f6f7adf3b533998.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="521" data-theme-name="nav links component"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_515_9e24f7655345082a5f8c1b9b94095b824b14c24b.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="515" data-theme-name="header"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_518_d52150defd3a34c305ea5a34ee83ec43bf77e38a.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="518" data-theme-name="hide buttons on review page"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_514_50e1c7598fba432eef766f599fa71fc0a71f80ff.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="514" data-theme-name="signup"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_516_0ed80da9219f9fb35cb8f6ca45d21cd118a2a3a0.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="516" data-theme-name="signup - onboard"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_517_822a181c87b3fc024e6d8fd07cc0df59d60615f6.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="517" data-theme-name="signup - set password"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_513_3cb54b7d09f3b7aaf388aed3b645317ccc89cc93.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="513" data-theme-name="sp ads"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_519_814aa50a4588a540ed483b04eb899af1f428c812.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="519" data-theme-name="staff name colors"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_512_667732a42aaa5bb37ac2328404af8346c4917f49.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="512" data-theme-name="topic post"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_522_94133cb53a98afbc4c99e3a4efc0eb4ffd067adb.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="522" data-theme-name="underline links in posts"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_511_07fcfdb8494d25f9fd416069099109ac346f1e16.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="511" data-theme-name="sitepoint"/>
    <!-- Proper Ad Script -->
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/6ef07837143d5fffd5fe4a7ddece907ed3758b1b.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-signup" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <h3 class="title"></h3>
    <div class="content-body">
      <div>
        <ul class="description"></ul>
        <label class="label-login"></label>
      </div>
      <form name="signup-form" id="signup-form" action="">
        <label class="error"></label>
        <input type="hidden" name="origin" value="community">
        <input type="text" name="username" placeholder="Username" required="">
        <input type="email" name="email" placeholder="Email" required="">
        <button class=" btn" type="submit"></button></form>
      
    </div>
    <div class="content-footer">
      <label class="label-social"></label>
      <div class="login-social"></div>
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/84c383874314c29a12824432b578dc9ec26ebfd2.js?__ws=www.sitepoint.com"></script>
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/12e8f1330bb2863428049315a91dd1bffef56849.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-onboard" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <div>
      <h3></h3>
      <p></p>
    </div>
    <div class="sp-modal__cover-container">
      <img class="sp-modal__cover" src="">
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/572fe22f3412926aca181dadbfa2d886f41f2ac0.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-set-password" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <h3></h3>
    <div>
      <p></p>
      <form name="set-password-form" id="set-password-form" action="" method="POST">
        <label class="error"></label>
        <input type="password" name="password" placeholder="Password" required="" minlength="10" pattern="(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).*">
        <label class="requirements"></label>
        <button class="btn" type="submit"></button></form>
      
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/00c03d9db1444f140c4a7e1847872155e4ec327d.js?__ws=www.sitepoint.com"></script>
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/bf19ff40fa9b3dffffada79ed67e9dd75d410132.js?__ws=www.sitepoint.com"></script>

<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/6962ee34197c5bcbce2f55a7e37b7f5bfbebf4b6.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

  <link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Removing addRandom and arrays from the multiplayer code&#39;" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624.rss" />
    <meta property="og:site_name" content="SitePoint Forums | Web Development &amp; Design Community" />
<meta property="og:type" content="website" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624/21" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624/21" />
<meta property="og:title" content="Removing addRandom and arrays from the multiplayer code" />
<meta name="twitter:title" content="Removing addRandom and arrays from the multiplayer code" />
<meta property="og:description" content="managePlayer or managePlayer.init?  being used more than once?  This is still not good is what you are saying?  https://jsfiddle.net/zfux48qn/  function onYouTubeIframeAPIReady() {   managePlayer.add(&quot;.playa&quot;, {     playerVars: {       start: 45     }   });    managePlayer.add(&quot;.playb&quot;, {     playerVars: {       playlist: &quot;0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g&quot;     }   });   managePlayer.add(&quot;.playc&quot;, {     playerVars: {       start: 45     }   });   manageCover.init({     container: &quot;..." />
<meta name="twitter:description" content="managePlayer or managePlayer.init?  being used more than once?  This is still not good is what you are saying?  https://jsfiddle.net/zfux48qn/  function onYouTubeIframeAPIReady() {   managePlayer.add(&quot;.playa&quot;, {     playerVars: {       start: 45     }   });    managePlayer.add(&quot;.playb&quot;, {     playerVars: {       playlist: &quot;0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g&quot;     }   });   managePlayer.add(&quot;.playc&quot;, {     playerVars: {       start: 45     }   });   manageCover.init({     container: &quot;..." />
<meta property="article:published_time" content="2021-09-18T23:14:11+00:00" />
<meta property="og:ignore_canonical" content="true" />


    
  </head>
  <body class="crawler">
    
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/fc4409811f1414056992ba3c59c61c7a42675242.js?__ws=www.sitepoint.com"></script>
<link href="https://fonts.googleapis.com/css?family=Roboto&amp;display=swap" rel="stylesheet">


<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/375663796349b60db60a837aa565d4b10840bbdd.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg" alt="SitePoint Forums | Web Development &amp; Design Community" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">Removing addRandom and arrays from the multiplayer code</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/javascript/33" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #d3a604'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>JavaScript</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-16T05:57:03Z'>
              <time itemprop='dateModified' datetime='2021-09-16T06:39:50Z' class='post-time'>
                September 16, 2021,  6:39am
              </time>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I started off with this code:<br>
<a href="https://jsfiddle.net/toyk5d7p/" rel="noopener nofollow ugc">https://jsfiddle.net/toyk5d7p/</a></p>
<p>Removing addRandom and arrays I am left with this:</p>
<p>I know that everything works in the code.<br>
It looks right to me.<br>
<a href="https://jsfiddle.net/orydf57j/" rel="noopener nofollow ugc">https://jsfiddle.net/orydf57j/</a></p>
<p>Did I do a good job?</p>
<p>Is there anything that needs to be changed?</p>
<pre><code class="lang-auto">const videoPlayer = (function makeVideoPlayer() {
    const players = [];

    const tag = document.createElement("script");
    tag.src = "https://www.youtube.com/player_api";
    const firstScriptTag = document.getElementsByTagName("script")[0];
    firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);

    function onPlayerReady(event) {
        const player = event.target;
        player.setVolume(100);
    }

    function addPlayer(video, settings) {
        const defaults = {
            height: 360,
            host: "https://www.youtube-nocookie.com",
            videoId: video.dataset.id,
            width: 640
        };
        defaults.events = {
            "onReady": onPlayerReady
        };

        const playerOptions = combinePlayerOptions(defaults, settings);
        const player = new YT.Player(video, playerOptions);
        players.push(player);
        return player;
    }

    return {
        addPlayer
    };
}());

const managePlayer = (function makeManagePlayer() {
    const defaults = {};
    defaults.playerVars = {
        autoplay: 0,
        controls: 0,
        disablekb: 1,
        enablejsapi: 1,
        fs: 0,
        iv_load_policy: 3
    };

    function show(el) {
        el.classList.remove("hide");
    }

    function createPlayer(videoWrapper, settings = {}) {
        const video = videoWrapper.querySelector(".video");
        const playerOptions = combinePlayerOptions(defaults, settings);
        return videoPlayer.addPlayer(video, playerOptions);
    }

    function createCoverClickHandler(playerSettings) {
        return function coverClickHandler(evt) {
            const cover = evt.currentTarget;
            const wrapper = cover.nextElementSibling;
            show(wrapper);
            const player = createPlayer(wrapper, playerSettings);
            wrapper.player = player;
        };
    }

    function addPlayer(coverSelector, playerSettings) {
        const clickHandler = createCoverClickHandler(playerSettings);
        manageCover.addCoverHandler(coverSelector, clickHandler);
    }

    function init(playerOptions) {
        Object.assign(defaults, playerOptions);
    }
    return {
        add: addPlayer,
        init
    };
}());

function onYouTubeIframeAPIReady() {
    managePlayer.init({
        playerVars: {
            controls: 1
        }
    });
    managePlayer.add(".playa", {
        playerVars: {
            start: 45
        }
    });

    managePlayer.add(".playb", {
        playerVars: {
            playlist: "0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g"
        }
    });
    managePlayer.add(".playc", {
        playerVars: {
            start: 45
        }
    });
    manageCover.init({
        container: ".container",
        playButton: ".thePlay"
    });
}
</code></pre>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-09-16T19:24:35Z' class='post-time'>
                September 16, 2021,  7:24pm
              </time>
              <meta itemprop='dateModified' content='2021-09-16T19:24:35Z'>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>The init function cannot use object.assign, as that destroys previous default options. Not only is combinePlayerOptions needed, but over writing defaults is a bad thing.  Better, is to have an options variable, inside of which is both the default options and the preferred options instead.</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-16T19:38:45Z'>
              <time itemprop='dateModified' datetime='2021-09-16T19:49:32Z' class='post-time'>
                September 16, 2021,  7:49pm
              </time>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Doing it this way am I still <strong>overwriting defaults</strong>?</p>
<p>What if I do this?</p>
<p>Is that better?</p>
<p>Only having playerVars in one spot.<br>
<a href="https://jsfiddle.net/ozg8ky2m/" rel="noopener nofollow ugc">https://jsfiddle.net/ozg8ky2m/</a></p>
<p><strong>This at the top:</strong></p>
<pre><code class="lang-auto">const managePlayer = (function makeManagePlayer() {
  const defaults = {};
</code></pre>
<p><strong>This at the bottom.</strong></p>
<pre><code class="lang-auto">function onYouTubeIframeAPIReady() {
  managePlayer.init({
    playerVars: {
      autoplay: 0,
      controls: 0,
      disablekb: 1,
      enablejsapi: 1,
      fs: 0,
      iv_load_policy: 3
    }
  });
</code></pre>
<p><strong>Full Code:</strong></p>
<pre><code class="lang-auto">const managePlayer = (function makeManagePlayer() {
  const defaults = {};

  function show(el) {
    el.classList.remove("hide");
  }

  function createPlayer(videoWrapper, settings = {}) {
    const video = videoWrapper.querySelector(".video");
    const playerOptions = combinePlayerOptions(defaults, settings);
    return videoPlayer.addPlayer(video, playerOptions);
  }

  function createCoverClickHandler(playerSettings) {
    return function coverClickHandler(evt) {
      const cover = evt.currentTarget;
      const wrapper = cover.nextElementSibling;
      show(wrapper);
      const player = createPlayer(wrapper, playerSettings);
      wrapper.player = player;
    };
  }

  function addPlayer(coverSelector, playerSettings) {
    const clickHandler = createCoverClickHandler(playerSettings);
    manageCover.addCoverHandler(coverSelector, clickHandler);
  }

  function init(playerOptions) {
    Object.assign(defaults, playerOptions);
  }
  return {
    add: addPlayer,
    init
  };
}());

function onYouTubeIframeAPIReady() {
  managePlayer.init({
    playerVars: {
      autoplay: 0,
      controls: 0,
      disablekb: 1,
      enablejsapi: 1,
      fs: 0,
      iv_load_policy: 3
    }
  });
</code></pre>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-16T22:45:53Z'>
              <time itemprop='dateModified' datetime='2021-09-16T22:46:58Z' class='post-time'>
                September 16, 2021, 10:46pm
              </time>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="asasass" data-post="3" data-topic="374624">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse-cdn.com/v4/letter/a/ee59a6/40.png" class="avatar"> asasass:</div>
<blockquote>
<p>Doing it this way am I still <strong>overwriting defaults</strong> ?</p>
</blockquote>
</aside>
<p>A good way to figure out if the defaults are being overwritten, is with 3 or more players.</p>
<p>That way you can use managePlayer.init before adding two of the players, then use managePlayer.init again to set a different type of setting that should be used by the third player.</p>
<p>The expected behaviour is that the settings from the first init should not appear after doing the second init.</p>
<p>Any variation from that expected behaviour (such as defaults getting destroyed, or previous init options living on through different init commands), is a problem.</p>
<p>How that is fixed is by not changing the defaults at all. Instead, you have init create a preferred set of options that combines the default options and the init options, and the rest of the code in there doesn’t use defaults at all, but uses that preferred combination instead.</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-16T22:48:16Z'>
              <time itemprop='dateModified' datetime='2021-09-17T00:41:32Z' class='post-time'>
                September 17, 2021, 12:41am
              </time>
          <span itemprop='position'>#5</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Yes, I want to implement that in the code.</p>
<p>How would I do that, as what you suggested I do?</p>
<blockquote>
<p>you have init create a preferred set of options that combines the default options and the init options, and the rest of the code in there doesn’t use defaults at all, but uses that preferred combination instead.</p>
</blockquote>
<p>In steps, how do I set the code up to do that?</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-09-17T01:03:18Z' class='post-time'>
                September 17, 2021,  1:03am
              </time>
              <meta itemprop='dateModified' content='2021-09-17T01:03:18Z'>
          <span itemprop='position'>#7</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Well right now you have manage.init followed by three managePlayer.add statements, and a final manage.init.</p>
<p>I recommend that you move that final manage.init up so that it’s somewhere inbetween the manage.add statements, and update the init statement so that it causes a default setting to occur that’s different  from controls.</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-17T01:05:55Z'>
              <time itemprop='dateModified' datetime='2021-09-17T01:16:31Z' class='post-time'>
                September 17, 2021,  1:16am
              </time>
          <span itemprop='position'>#8</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Like this? Did I do that right?<br>
<a href="https://jsfiddle.net/spc9wz0u/" rel="noopener nofollow ugc">https://jsfiddle.net/spc9wz0u/</a></p>
<p>If that is good, what do I do next?</p>
<pre><code class="lang-auto">function onYouTubeIframeAPIReady() {
  managePlayer.init({
    playerVars: {
      autoplay: 0,
      controls: 1,
      disablekb: 1,
      enablejsapi: 1,
      fs: 0,
      iv_load_policy: 3
    }
  });

  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });
}

managePlayer.add(".playa", {
  playerVars: {
    start: 45
  }
});

managePlayer.add(".playb", {
  playerVars: {
    playlist: "0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g"
  }
});
managePlayer.add(".playc", {
  playerVars: {
    start: 45
  }
});
</code></pre>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-09-17T05:12:40Z' class='post-time'>
                September 17, 2021,  5:12am
              </time>
              <meta itemprop='dateModified' content='2021-09-17T05:12:40Z'>
          <span itemprop='position'>#9</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>No, you didn’t do it right at all.</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-17T09:05:00Z'>
              <time itemprop='dateModified' datetime='2021-09-17T13:51:31Z' class='post-time'>
                September 17, 2021,  1:51pm
              </time>
          <span itemprop='position'>#10</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><strong>Step 1</strong></p>
<blockquote>
<p>move that final manage.init up so that it’s somewhere inbetween the manage.add statements</p>
</blockquote>
<p><strong>If this way is wrong:</strong></p>
<pre><code class="lang-auto"> managePlayer.init({
    playerVars: {
      autoplay: 0,
      controls: 1,
      disablekb: 1,
      enablejsapi: 1,
      fs: 0,
      iv_load_policy: 3
    }
  });

  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });
}

managePlayer.add(".playa", {
  playerVars: {
    start: 45
  }
});
</code></pre>
<p>I can try this again.</p>
<p>Doing this would place: <code>manageCover.init({</code> <strong>in-between</strong> <code>managePlayer.add(".playa",</code> <strong>and</strong> <code>managePlayer.add(".playb",</code></p>
<p><strong>Like this?</strong></p>
<p>Is that right?<br>
<a href="https://jsfiddle.net/ho1t2sgb/" rel="noopener nofollow ugc">https://jsfiddle.net/ho1t2sgb/</a></p>
<pre><code class="lang-auto">  managePlayer.init({
    playerVars: {
      autoplay: 0,
      controls: 1,
      disablekb: 1,
      enablejsapi: 1,
      fs: 0,
      iv_load_policy: 3
    }
  });

  managePlayer.add(".playa", {
    playerVars: {
      start: 45
    }
  });

  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });

  managePlayer.add(".playb", {
    playerVars: {
      playlist: "0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g"
    }
  });

  managePlayer.add(".playc", {
    playerVars: {
      start: 45
    }
  });
}
</code></pre>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-17T14:13:44Z'>
              <time itemprop='dateModified' datetime='2021-09-17T16:41:09Z' class='post-time'>
                September 17, 2021,  4:41pm
              </time>
          <span itemprop='position'>#11</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>If that is right, how I fixed it.<br>
<a href="https://jsfiddle.net/ho1t2sgb/" rel="noopener nofollow ugc">https://jsfiddle.net/ho1t2sgb/</a></p>
<p><strong>Step 2</strong></p>
<blockquote>
<p>update the init statement so that it causes a default setting to occur that’s different from controls.</p>
</blockquote>
<p>How do I do that?</p>
<p>What do I add, change/remove in the code to reflect that?</p>
<pre><code class="lang-auto">const managePlayer = (function makeManagePlayer() {
  const defaults = {};

  function show(el) {
    el.classList.remove("hide");
  }

  function createPlayer(videoWrapper, settings = {}) {
    const video = videoWrapper.querySelector(".video");
    const playerOptions = combinePlayerOptions(defaults, settings);
    return videoPlayer.addPlayer(video, playerOptions);
  }

  function createCoverClickHandler(playerSettings) {
    return function coverClickHandler(evt) {
      const cover = evt.currentTarget;
      const wrapper = cover.nextElementSibling;
      show(wrapper);
      const player = createPlayer(wrapper, playerSettings);
      wrapper.player = player;
    };
  }

  function addPlayer(coverSelector, playerSettings) {
    const clickHandler = createCoverClickHandler(playerSettings);
    manageCover.addCoverHandler(coverSelector, clickHandler);
  }

  function init(playerOptions) {
    Object.assign(defaults, playerOptions);
  }
  return {
    add: addPlayer,
    init
  };
}());

function onYouTubeIframeAPIReady() {
  managePlayer.init({
    playerVars: {
      autoplay: 0,
      controls: 1,
      disablekb: 1,
      enablejsapi: 1,
      fs: 0,
      iv_load_policy: 3
    }
  });

  managePlayer.add(".playa", {
    playerVars: {
      start: 45
    }
  });

  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });

  managePlayer.add(".playb", {
    playerVars: {
      playlist: "0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g"
    }
  });

  managePlayer.add(".playc", {
    playerVars: {
      start: 45
    }
  });
}
</code></pre>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-09-17T20:18:41Z' class='post-time'>
                September 17, 2021,  8:18pm
              </time>
              <meta itemprop='dateModified' content='2021-09-17T20:18:41Z'>
          <span itemprop='position'>#12</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I was recommending that you have an init, add, add, init, and add, in that order, with the inits being for different types of player options.</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-17T20:21:49Z'>
              <time itemprop='dateModified' datetime='2021-09-18T00:21:33Z' class='post-time'>
                September 18, 2021, 12:21am
              </time>
          <span itemprop='position'>#13</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>You never said explicitly what each of the init’s you were referring to.</p>
<p>I was confused because of that.</p>
<p>Like this? <strong>1st</strong><br>
<a href="https://jsfiddle.net/rw7ukgaf/" rel="noopener nofollow ugc">https://jsfiddle.net/rw7ukgaf/</a></p>
<pre><code class="lang-auto">  managePlayer.init({
    playerVars: {
    }
  });
managePlayer.add
managePlayer.add
  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });
managePlayer.add
</code></pre>
<p>or this way? <strong>2nd</strong><br>
<a href="https://jsfiddle.net/qb8pydrn/" rel="noopener nofollow ugc">https://jsfiddle.net/qb8pydrn/</a></p>
<p>You would be referring to <strong>this way</strong> then, right?</p>
<blockquote>
<p>with the inits being for different types of player options.</p>
</blockquote>
<p>This one has player options between the add’s</p>
<pre><code class="lang-auto">  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });
managePlayer.add
managePlayer.add
  managePlayer.init({
    playerVars: {
    }
  });
managePlayer.add
</code></pre>
<p>After that how do I do this?</p>
<blockquote>
<p>update the init statement so that it causes a default setting to occur that’s different from controls.</p>
</blockquote>
<p>Which is what I would be doing, next, right?</p>
<p>I don’t know how that would be done.</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-18T05:12:23Z'>
              <time itemprop='dateModified' datetime='2021-09-18T06:16:45Z' class='post-time'>
                September 18, 2021,  6:16am
              </time>
          <span itemprop='position'>#14</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Are either one of those correct, or am I still misunderstanding what you want me to do?</p>
<p><strong>1st</strong> Way:<br>
<a href="https://jsfiddle.net/rw7ukgaf/" rel="noopener nofollow ugc">https://jsfiddle.net/rw7ukgaf/</a></p>
<pre><code class="lang-auto">managePlayer.init({
managePlayer.add
managePlayer.add
manageCover.init({
managePlayer.add
</code></pre>
<p><strong>2nd</strong> Way:<br>
<a href="https://jsfiddle.net/qb8pydrn/" rel="noopener nofollow ugc">https://jsfiddle.net/qb8pydrn/</a></p>
<pre><code class="lang-auto">manageCover.init({
managePlayer.add
managePlayer.add
managePlayer.init({
managePlayer.add
</code></pre>
<p>If one of those is what you were recommending, after that, I am supposed to do this which I don’t know how to do.</p>
<blockquote>
<p>update the init statement so that it causes a default setting to occur that’s different from controls.</p>
</blockquote>
<p>I don’t understand how to write that into the code.</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-09-18T11:04:48Z' class='post-time'>
                September 18, 2021, 11:04am
              </time>
              <meta itemprop='dateModified' content='2021-09-18T11:04:48Z'>
          <span itemprop='position'>#15</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>It should all be managePlayer.</p>
<p>That way with the first init you can set start to be 45, and with the second init you can set a different option such as playlist to be some videos.</p>
<p>That way you can easily examine the resulting behaviour of the third video that loads after the last init.<br>
If that last video still starts at 45 seconds, that is confirmation that earlier init settings are inappropriately being maintained.</p>
<p>The expected behaviour is that the managePlayer defaults are being added only to the most recent init. Anything else such as what I’ve just explained, is a problem that needs to be fixed. It’s an easy fix too, but in my experience you need very easy ways to observe and experience the problem, which what I’m directing you to achieve.</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">

            <link itemprop="image" href="https://aws1.discourse-cdn.com/sitepoint/original/3X/d/b/dbae3b49cea2f4d2e3f3315460145a8dda43338c.png">

          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-18T13:09:40Z'>
              <time itemprop='dateModified' datetime='2021-09-18T17:29:24Z' class='post-time'>
                September 18, 2021,  5:29pm
              </time>
          <span itemprop='position'>#17</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Can I do this, is this better?</p>
<p>Is there anything wrong here?<br>
<a href="https://jsfiddle.net/fdujqvo6/" rel="noopener nofollow ugc">https://jsfiddle.net/fdujqvo6/</a></p>
<p>You keep telling me defaults are being destroyed/overwritten, but if I can’t see that without using <code>console.log()</code>, I am going to keep making the same mistakes, over and over again.</p>
<p>I don’t know how to use <code>console.log()</code> to be able to know if defaults are or are not being destroyed here.</p>
<p>Can you show me how to do that?</p>
<p>How many console logs am I adding?</p>
<p>Like this?<br>
<a href="https://jsfiddle.net/xohctk17/1/" rel="noopener nofollow ugc">https://jsfiddle.net/xohctk17/1/</a></p>
<pre><code class="lang-auto">  defaults.playerVars = {
    autoplay: 0,
    controls: 0,
    disablekb: 1,
    enablejsapi: 1,
    fs: 0,
    iv_load_policy: 3
  };console.log(defaults);
</code></pre>
<p>                    <a href="https://aws1.discourse-cdn.com/sitepoint/original/3X/d/b/dbae3b49cea2f4d2e3f3315460145a8dda43338c.png" target="_blank" rel="noopener nofollow ugc" class="onebox">
            <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/d/b/dbae3b49cea2f4d2e3f3315460145a8dda43338c.png" width="165" height="137">
          </a>

</p>
<p>Placing a <code>console.log()</code> in here like this?</p>
<pre><code class="lang-auto">  managePlayer.add(".playa", {
    playerVars: {
      start: 45
    }
  });console.log(managePlayer);
</code></pre>
<p>This comes up in console.<br>
<img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/b/8b186e8b09fc8dbcf49a30dbc305245f4bea45d7.png" alt="" data-base62-sha1="jQuIdVP17MN9UuafIgMJ5kI8Juv" width="442" height="73"></p>
<p>Also, inside the console I don’t know what behavior I am supposed to be looking for in terms of what behavior I want to avoid, and the behavior I am looking to achieve.</p>
<p>Inside console, can you show me the behavior I want to avoid, and the behavior it should be saying instead?</p>
<p><strong>Example:</strong></p>
<p>Defaults being destroyed looks like this inside console.<br>
This is the behavior I want to avoid.</p>
<p>Defaults not being destroyed, looks like this inside console.<br>
This is the behavior that should be happening in the code.</p>
<pre><code class="lang-auto">const managePlayer = (function makeManagePlayer() {
  const defaults = {};
  defaults.playerVars = {
    autoplay: 0,
    controls: 0,
    disablekb: 1,
    enablejsapi: 1,
    fs: 0,
    iv_load_policy: 3
  };

  function show(el) {
    el.classList.remove("hide");
  }

  function createPlayer(videoWrapper, settings = {}) {
    const video = videoWrapper.querySelector(".video");
    const playerOptions = combinePlayerOptions(defaults, settings);
    return videoPlayer.addPlayer(video, playerOptions);
  }

  function createCoverClickHandler(playerSettings) {
    return function coverClickHandler(evt) {
      const cover = evt.currentTarget;
      const wrapper = cover.nextElementSibling;
      show(wrapper);
      const player = createPlayer(wrapper, playerSettings);
      wrapper.player = player;
    };
  }

  function addPlayer(coverSelector, playerSettings) {
    const clickHandler = createCoverClickHandler(playerSettings);
    manageCover.addCoverHandler(coverSelector, clickHandler);
  }

  return {
    add: addPlayer
  };
}());

function onYouTubeIframeAPIReady() {
  managePlayer.add(".playa", {
    playerVars: {
      start: 45
    }
  });

  managePlayer.add(".playb", {
    playerVars: {
      playlist: "0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g"
    }
  });
  managePlayer.add(".playc", {
    playerVars: {
      start: 45
    }
  });
  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });
}

</code></pre>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-09-18T22:41:23Z' class='post-time'>
                September 18, 2021, 10:41pm
              </time>
              <meta itemprop='dateModified' content='2021-09-18T22:41:23Z'>
          <span itemprop='position'>#18</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>The whole point if doing it is because there is a problem when managePlayer.init is used more than once.</p>
<p>Is that a problem that you are wanting to be solved?</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="3" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-18T22:45:06Z'>
              <time itemprop='dateModified' datetime='2021-09-18T22:51:24Z' class='post-time'>
                September 18, 2021, 10:51pm
              </time>
          <span itemprop='position'>#19</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Are you saying that, if <code>managePlayer.init</code> is not being used in here, then,<br>
there is no issue at all?</p>
<p>The issue only arises when <code>managePlayer.init</code> is being used?</p>
<p>Which is <strong>not</strong> the case in this code:</p>
<p><strong>This code is fine is what you are saying:</strong><br>
<a href="https://jsfiddle.net/zfux48qn/" rel="noopener nofollow ugc">https://jsfiddle.net/zfux48qn/</a></p>
<pre><code class="lang-auto">function onYouTubeIframeAPIReady() {
  managePlayer.add(".playa", {
    playerVars: {
      start: 45
    }
  });

  managePlayer.add(".playb", {
    playerVars: {
      playlist: "0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g"
    }
  });
  managePlayer.add(".playc", {
    playerVars: {
      start: 45
    }
  });
  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });
}
</code></pre>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-18T22:58:42Z'>
              <time itemprop='dateModified' datetime='2021-09-18T23:10:05Z' class='post-time'>
                September 18, 2021, 11:10pm
              </time>
          <span itemprop='position'>#20</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Thank you for the clarification</p>
<p>The way these are set up, one of these would need to be fixed is what you are saying.</p>
<p>How is <code>managePlayer.init</code> being used more than once here?</p>
<p>You’re referring to just these?</p>
<pre><code class="lang-auto">managePlayer.init({
managePlayer.add
managePlayer.add
managePlayer.add
</code></pre>
<p>This should be the last init, at the end, unless I am wrong.<br>
<code>manageCover.init({</code> is separate by itself, it’s not part of the others.</p>
<p>This only deals with the cover and should remain at the end.</p>
<p>This shouldn’t be touched, or changed at all, right?</p>
<pre><code class="lang-auto">  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });
</code></pre>
<p><strong>To this point</strong>, I am so confused on what I should be doing, and what you said in this post does not make sense to me. <a href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624/15">Post # 15</a></p>
<p><strong>This is what I am thinking:</strong></p>
<pre><code class="lang-auto">managePlayer.add
managePlayer.add
managePlayer.init({
managePlayer.add
</code></pre>
<p>This one should stay at the end and not be touched.<br>
<code>manageCover.init({</code></p>
<p>I am not going to be able to understand this because this is all so confusing to me.</p>
<p><strong>1st</strong> Way:<br>
<a href="https://jsfiddle.net/rw7ukgaf/" rel="noopener nofollow ugc">https://jsfiddle.net/rw7ukgaf/</a></p>
<pre><code class="lang-auto">managePlayer.init({
managePlayer.add
managePlayer.add
manageCover.init({
managePlayer.add
</code></pre>
<p><strong>2nd</strong> Way:<br>
<a href="https://jsfiddle.net/qb8pydrn/" rel="noopener nofollow ugc">https://jsfiddle.net/qb8pydrn/</a></p>
<pre><code class="lang-auto">manageCover.init({
managePlayer.add
managePlayer.add
managePlayer.init({
managePlayer.add
</code></pre>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/asasass'><span itemprop='name'>asasass</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/removing-addrandom-and-arrays-from-the-multiplayer-code/374624">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2021-09-18T23:14:11Z'>
              <time itemprop='dateModified' datetime='2021-09-18T23:25:28Z' class='post-time'>
                September 18, 2021, 11:25pm
              </time>
          <span itemprop='position'>#21</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><code>managePlayer</code> <strong>or</strong> <code>managePlayer.init</code>?</p>
<p>being used more than once?</p>
<p>This is still <strong>not good</strong> is what you are saying?<br>
<a href="https://jsfiddle.net/zfux48qn/" rel="noopener nofollow ugc">https://jsfiddle.net/zfux48qn/</a></p>
<pre><code class="lang-auto">function onYouTubeIframeAPIReady() {
  managePlayer.add(".playa", {
    playerVars: {
      start: 45
    }
  });

  managePlayer.add(".playb", {
    playerVars: {
      playlist: "0dgNc5S8cLI,mnfmQe8Mv1g,-Xgi_way56U,CHahce95B1g"
    }
  });
  managePlayer.add(".playc", {
    playerVars: {
      start: 45
    }
  });
  manageCover.init({
    container: ".container",
    playButton: ".thePlay"
  });
}
</code></pre>
<p>Or is it <strong>only not good</strong> if this is being used <strong>also</strong>?</p>
<p><code>managePlayer.init</code> ?</p>
<p><strong>Meaning:</strong> <code>managePlayer.init</code> in conjunction with 3 of these is not good.</p>
<pre><code class="lang-auto">managePlayer.add
managePlayer.add
managePlayer.add
</code></pre>
<p>These are fine and there is no issue with that?</p>
<pre><code class="lang-auto">managePlayer.add
managePlayer.add
managePlayer.add
</code></pre>
<p>The issue only arises when <code>managePlayer.init</code> is being used in there also?</p>
<p>Is that a better understanding of what you mean?</p>
        </div>

        <meta itemprop='headline' content='Removing addRandom and arrays from the multiplayer code'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <div id="footer-ad-spacer"></div>
<div id="footer-ad" class="proper-ad-unit ad-sticky">

    
     <div id="proper-ad-sitepoint_left_sticky">  </div>
     
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/be63710d6fb6a95a92f8c7ea8836704b560e4661.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
