Problem With Monitis Agent

I use a service called Monitor.us to keep track of the up/down habits of a few of my more important hosted sites (on various servers).

They use a script called Monitis which is evidently fairly popular to broadcast system critical information back to my dashboard to alert me of any problems.

I’m getting the script installed and configured but when running it it throws the following error:

/home/---username---/public_html/monitis/bin/monitis: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /home/---username---/public_html/monitis/bin/monitis)

I’m fairly “linux dumb” but there is a file at /lib/libc.so and I ran “yum install glibc” hoping that would install something that was dependant but I’m still unable to start this script / service.

I’m on an i686 32bit machine and have tried to install this on 2 different servers.

Thanks for any help.

our agents are build with GLIB 2.7 version so in case you have version older than that it won’t work, you need to contact us to our support e-mails and we will send you the version with the older versions supported.

That one has already been answered - I’m going to guess the server you are trying to run it on is quite old / out of date when it comes to the core libraries. Best answer is to get a copy of monitis that has been compiled for your distro of choice. However, if this is not possible maybe consider bringing the server more up to date? What distro is it?