Problem displaying twitter feed, based on sitepoint code

I set up a page to display tweets for a client, based on the code in Craig Buckler’s article -

Now after running happily for over 18 months, it’s stopped working. Don’t know when it stopped, I only check their pages occasionally.

Anyone else who has used Craig’s code having this problem? Anyone got a solution?

I believe Twitter have pulled the RSS support. The code calls (for example):

This is no longer available. Someone who knows more about it than me can explain how to achieve it but I think you have to give permission to the app your building to use the feeds.

The API endpoint has changed, it’s now located at

The data structure may have changed too, so you may want check the returned data.

I’ve tried editing the API line in the original code to match the link above, but it still doesn’t want to play. The changes in that line where obvious, even to me.

Pity that Craig said there was no support with the code which he wrote. I could find the items he extracts in the string that is returned in the link given above, no obvious change of name for the parts either.

I created a test environment, and I got it to work by removing the cache files then changing line 144 in twitterstatus.php to:

CURLOPT_URL => '' . $this->ID . '&count=' . $this->Count,

FWIW, Craig states on line 10 of that same file “This code can be used without any restrictions, but please don’t expect support either!”. :wink:

Thanks Anthony!

I’ve been out all day and just seen this. I’d edited the same line almost the same way, but didn’t touch the cache. I added the /1/, which I’d somehow missed when looking at your original post, cleared the cache, and it worked.