Pretty Url Problems


Other members have asked their hosts to restart and, with the explanation of the erroneous redirection, they’ve always been happy to do it. If not, then 1&1 is reputed to be a terrible host so it might enable you to find a good host to provide the service you should expect (and must demand).



Hi DK,

I was actually able to make it work by fiddling with the code a bit:

Options +FollowSymlinks -MultiViews
RewriteEngine On 
RewriteCond %{SCRIPT_FILENAME} !-d  
RewriteCond %{SCRIPT_FILENAME} !-f 
RewriteRule ^author/([a-zA-Z0-9-]+)(/?)$ /author.php?name=$1

I’m not entirely sure why it worked this time instead of the times before.

Also one last question, i know you mentioned before there were 2 ways to fix the issue that would arise with the css, js and other attached files, i know i could change everything to absolute url’s but i would rather not do that, i know another option could be to include the files using PHP, so that the style sheet is internal. I this a viable option or is there a better solution.

EDIT: NM, i figured it out i just used the <base> tag.

Thanks for all the help everyone,