Posts page showing homepage why?

Whenever I click on blog to show the posts, it takes me to the homepage. even if I change it to the default template. How can I fix this?

click here to see this weird posts problem.


Thank you

Nate that makes a lot of sense! When I installed the site I got some .htaccess errors. How do I open it?


I opened it with notepad all is says is

BEGIN WordPress

END WordPress

I have this: (can’t remember where it came from)

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpress/
RewriteCond &#37;{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpress/index.php [L]

# END WordPress

which lets me take advantage of Apache’s URL Rewrite facility and use permalinks set to a Custom value of /%postname%/ - so one page can refer to another by name, e.g.

Please <a href="wordpress/contact/">contact us</a>

where the page URL is


(in your case you would replace ‘wordpress’ with ‘pennywp’).

(BTW, I see that you got the Penny’s Blog page to show up! A step in the right direction! :magic: )

Thank you!

Thank you for your reply, however, no matter what page I set it to, it goes to that homepage. It’s already set to my posts page, that’s why this problem is so weird. is there anyway to find out the id of the posts page, maybe I can change that permalink manually.

Thanks again, jvic.

Ok, when I set Front page displays - your latest posts. I get what I get now, click on the link above. it says homepage id is ?page_id=109, and posts page url is ?page_id=29. It seems to be confusing the pages. If I change the permalinks to /%category%/%postname%/ which I would like it to be, the site gets very gltichy. When I set it to Front page displays - static page, I get both the posts page and the home page have ?page_id=29.

That’s Permalinks you’re talking about and yeah, it’ll get funky if your .htaccess wasn’t generated properly or has issues.

Make sure your .htaccess file is there and has something in it.

if you go to your site’s wp-admin page, then look for Settings down near the bottom of the menu. Look at ‘Reading’ and you will see two fields: Posts Page and Front Page. You want the Posts page to be the one that has your Blog.

hope it helps…