POST Header

Hey all, I didn’t really know where to put this post so if there is a better place please let me know. I’m having some trouble with a little program I’m making at the moment - this actually has nothing to do with PHP but I’m sure someone here will know what I’m talking about.

I’m writing a program to automatically login to yedda.com. The program posts a GET request to yedda.com/signin/ to start off, it stores the cookies which were specified in the response header via “Set-Cookie:” and gets the hidden form values. Then I send a POST request to yedda.com/signin/ with the cookies and arguments.

Problem: Yedda is returning a page saying I have cookies disabled or something. So I guess I’m doing something wrong with the cookies. Can you take a look at this:

(Note: There is a pile of javascript associated with the form I’m dealing with, however when I disabled js in IE I had no problems logging in, so I’m neglecting the JS, is this alright?)

The response header to my GET request. (Not showing the content that follows)


HTTP/1.1 200 OK

Server: Microsoft-IIS/6.0

p3p: CP="IDC DSP COR ADM DEVi TAIi PSA PSD IVAi IVDi CONi HIS OUR IND CNT"

Etag:

X-Powered-By: ASP.NET

X-AspNet-Version: 2.0.50727

X-Yedda-PD: m=YEDDAWEB8 et=15.625 drc=na drt=na dwc=1 dwt=0 crc=1 crt=0 cwc=na cwt=na

Set-Cookie: ASP.NET_SessionId=d2l2pbusae0hs245stkxjbuk; path=/; HttpOnly

Set-Cookie: refdata=; domain=yedda.com; path=/

Set-Cookie: yfbi=; domain=yedda.com; path=/

Set-Cookie: testCookie=testCookie; path=/

Cache-Control: no-cache

Pragma: no-cache

Expires: -1

Content-Type: text/html; charset=utf-8

Content-Length: 28824

Date: Fri, 05 Feb 2010 01:54:41 GMT

X-Varnish: 1185603068

Age: 0

Via: 1.1 varnish

Connection: close

X-Cache: MISS

My POST request (I’ve used URL encoding for the cookies and args and replaced my actual username and password):


POST /signin/ HTTP/1.1

Host: yedda.com

User-Agent: AAP

Content-Length: 2972

Content-Type: application/x-www-form-urlencoded

Connection: close

Cookie: ASP%2eNET%5fSessionId=d2l2pbusae0hs245stkxjbuk;

Cookie: refdata=;

Cookie: yfbi=;

Cookie: testCookie=testCookie;


%5f%5fVIEWSTATE=%2fwEPDwUKMTc1MDEzNDQxNQ9kFgJmD2QWAgIDD2QWBGYPDxYCHghJbWFnZVVybAUyaHR0cDovL2NzYi55ZWRkYS5jb20vY3N0cmFjay8wLz82MzQwMDkzMTcxNjE1MjYyNTAWAh4Fc3R5bGUFDWRpc3BsYXk6bm9uZTtkAgIPZBYEAgEPZBYEAgEPDxYCHgdWaXNpYmxlaGRkAgIPZBYEAgMPZBYCAgEPZBYCAgEPZBYEAgEPDxYCHgtOYXZpZ2F0ZVVybAURaHR0cDovL3llZGRhLmNvbS8WAh4DcmVsBQRob21lFgJmDw8WAh8ABTxodHRwOi8vc3RhdGljMS55ZWRkYWNkbi5jb20vaW1hZ2VzL0xvZ28xMzJYNDZfcm10OWMxZDIyZC5qcGcWBB4Fd2lkdGgFBTEyOXB4HgZoZWlnaHQFBDQ2cHhkAgMPZBYCAgEPFgIeBFRleHQFJVBlb3BsZS48YnIgLz5TaGFyaW5nLjxiciAvPktub3dsZWRnZS5kAgUPZBYEAgEPZBYmZg8PZBYCHgVjbGFzcwUKTG9nb3V0TGluaxYEZg8PFgIfBwUNU2lnbmVkIGluIGFzIGRkAgIPDxYCHwMFEi9zaWdub3V0Lz90aGFua3lvdWRkAgEPDxYCHwJoZGQCAg8PZBYEHwUFAzNweB8GBQQxMXB4ZAIDDw8WAh8DBRpodHRwOi8veWVkZGEuY29tL2ZlZWRiYWNrL2RkAgQPDxYCHwMFGmh0dHA6Ly95ZWRkYS5jb20vZmVlZGJhY2svZGQCBg8PFgIfAwURaHR0cDovL3llZGRhLmNvbS9kZAIHDw9kFgQfBQUDM3B4HwYFBDExcHhkAggPDxYCHwMFJ2h0dHA6Ly95ZWRkYS5jb20vcXVlc3Rpb25zL25ldy8%2fZWRpdE5ld2RkAgkPD2QWBB8FBQMzcHgfBgUEMTFweGQCCg8PFgIfAwUwaHR0cDovL3llZGRhLmNvbS9hY3Rpdml0eS9xdWVzdGlvbnMvaW50ZXJlc3RpbmcvZGQCCw8PZBYEHwUFAzNweB8GBQQxMXB4ZAIMDw8WAh8DBRpodHRwOi8veWVkZGEuY29tL2FjdGl2aXR5L2RkAg0PD2QWBB8FBQMzcHgfBgUEMTFweGQCDw8PZBYEHwUFAzNweB8GBQQxMXB4ZAIQD2QWBGYPDxYCHwMFJ2h0dHBzOi8veWVkZGEuY29tL3NpZ251cC8%2fUmV0dXJuVXJsPSUyZmRkAgEPD2QWBB8FBQMzcHgfBgUEMTFweGQCEQ8PFgIfAwUZaHR0cDovL3llZGRhLmNvbS9leHBsb3JlL2RkAhIPD2QWBB8FBQMzcHgfBgUEMTFweGQCEw8PFgIfAwUcaHR0cDovL3llZGRhLmNvbS9jYXRlZ29yaWVzL2RkAhQPFgIfAmhkAgMPDxYCHwAFS2h0dHA6Ly9zdGF0aWMxLnllZGRhY2RuLmNvbS9pbWFnZXMvSGVhZGVyQm90dG9tU2VwYXJhdG9yV2lkZV9ybXQ5YzFkMjJkLmdpZhYEHwUFBTk4MHB4HwYFAzFweGQCAw9kFgICBQ9kFgoCAQ8PFgIfAmhkFgICAQ8PFgIfB2VkZAIDDxYCHwgFDlNpZ25Jbk1haW5MZWZ0FggCAw8PZBYEHwUFBTEwOHB4HwYFBTI0MXB4ZAIJDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAINDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAIRDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAIVDw8WAh8DBQ8vc2lnbmluL2ZvcmdvdC9kZAIZDxYCHwgFD1NpZ25JbkJ1dHRvbkRpdmQCGw9kFgJmD2QWBgIFDxYCHgdvbmNsaWNrBT53aW5kb3cubG9jYXRpb24uaHJlZj0naHR0cHM6Ly95ZWRkYS5jb20vc2lnbnVwLz9SZXR1cm5Vcmw9JTJmJxYGAgEPD2QWBB8FBQMzcHgfBgUEMzlweGQCAw9kFgICAQ8PZBYEHwUFAzJweB8GBQQzOXB4ZAIFDw9kFgQfBQUDNXB4HwYFBDM5cHhkAgcPDxYCHwMFEWh0dHA6Ly95ZWRkYS5jb20vZBYCZg8PZBYEHwUFBDQ4cHgfBgUEMTdweGQCCQ8PZBYEHwUFBTEzMnB4HwYFBDIxcHhkGAcFQmN0bDAwJEZvb3RlckNvbnRyb2wxJEZvb3RlckZvclBhcnRuZXJzMSRNdWx0aXZpZXdGb290ZXJGb3JQYXJ0bmVycw8PZGZkBS1jdGwwMCRIZWFkZXJDb250cm9sMSRNdWx0aVZpZXdDdXN0b21pemFibGVMbkYPD2QCAWQFJGN0bDAwJEZvb3RlckNvbnRyb2wxJE11bHRpVmlld0Zvb3Rlcg8PZGZkBSFjdGwwMCRNYWluJE11bHRpdmlld1NpZ25Jbk1lc3NhZ2UPD2RmZAUeX19Db250cm9sc1JlcXVpcmVQb3N0QmFja0tleV9fFgEFHGN0bDAwJE1haW4kQ2hlY2tCb3hSZW1lYmVyTWUFVWN0bDAwJEZvb3RlckNvbnRyb2wxJExhbmdGb290ZXJDb250cm9sMSRGb290ZXJGb3JQYXJ0bmVyczEkTXVsdGl2aWV3Rm9vdGVyRm9yUGFydG5lcnMPD2QCAWQFHmN0bDAwJE1haW4kTXVsdGlWaWV3U2lnblVwTGluaw8PZGZkcslQE74IJyrHmJ5KX8dtsRpfAFs%3d&%5f%5fEVENTVALIDATION=%2fwEWBQL5tKHDDwKCuJy7DwLJx9%2b1AQLwrpv3BQLQ98K0AnXUcWprSdFqsMbzHNtLIHp0a09a&ctl00%24Main%24TextBoxSignInUsername=URLEncodedUserName&ctl00%24Main%24TextBoxSignInPassword=URLEncodedPW


And then finnaly the response to my POST request:


HTTP/1.1 200 OK

Server: Microsoft-IIS/6.0

p3p: CP="IDC DSP COR ADM DEVi TAIi PSA PSD IVAi IVDi CONi HIS OUR IND CNT"

Etag:

X-Powered-By: ASP.NET

X-AspNet-Version: 2.0.50727

Set-Cookie: ASP.NET_SessionId=eqbofv45xxkugj455cridx55; path=/; HttpOnly

Set-Cookie: refdata=; domain=yedda.com; path=/

Set-Cookie: yfbi=; domain=yedda.com; path=/

Cache-Control: no-cache

Pragma: no-cache

Expires: -1

Content-Type: text/html; charset=utf-8

Content-Length: 29255

Date: Fri, 05 Feb 2010 01:54:43 GMT

X-Varnish: 1185603144

Age: 0

Via: 1.1 varnish

Connection: close

X-Cache: MISS

....
.... (Skipping to relevant content)

        <div class="SignInDetails">

                <span id="ctl00_Main_CustomValidatorTestCookies" class="SignInErrorMessage"><font color="#E04228">We are sorry, your browser does not support cookies or cookies are disabled. Please enable cookies and try again.</font></span>	
	

Not sure why this is happening, can anyone see anything wrong with my post request?

Thanks in advance,

Nick :slight_smile:

Yeah, it looks like you may have urlencoded the cookie keys before sending them back or something.

ASP.NET_SessionId became ASP%2eNET%5fSessionId when you sent it back

Haha yeah I did, should I not do that? Because either way I still get the same response… I’m stumped. Here’s the post request without cookie encoding.

POST /signin/ HTTP/1.1

Host: yedda.com

User-Agent: AAP

Content-Length: 2974

Content-Type: application/x-www-form-urlencoded

Connection: close

Cookie: ASP.NET_SessionId=xy5gh2y3x0iswt55kz5qot45;

Cookie: refdata=;

Cookie: yfbi=;

Cookie: testCookie=testCookie;


&#37;5f%5fVIEWSTATE=%2fwEPDwUKMTc1MDEzNDQxNQ9kFgJmD2QWAgIDD2QWBGYPDxYCHghJbWFnZVVybAUyaHR0cDovL2NzYi55ZWRkYS5jb20vY3N0cmFjay8wLz82MzQwMDkzNjkxMjgzNTAwMDAWAh4Fc3R5bGUFDWRpc3BsYXk6bm9uZTtkAgIPZBYEAgEPZBYEAgEPDxYCHgdWaXNpYmxlaGRkAgIPZBYEAgMPZBYCAgEPZBYCAgEPZBYEAgEPDxYCHgtOYXZpZ2F0ZVVybAURaHR0cDovL3llZGRhLmNvbS8WAh4DcmVsBQRob21lFgJmDw8WAh8ABTxodHRwOi8vc3RhdGljMS55ZWRkYWNkbi5jb20vaW1hZ2VzL0xvZ28xMzJYNDZfcm10OWMxZDIyZC5qcGcWBB4Fd2lkdGgFBTEyOXB4HgZoZWlnaHQFBDQ2cHhkAgMPZBYCAgEPFgIeBFRleHQFJVBlb3BsZS48YnIgLz5TaGFyaW5nLjxiciAvPktub3dsZWRnZS5kAgUPZBYEAgEPZBYmZg8PZBYCHgVjbGFzcwUKTG9nb3V0TGluaxYEZg8PFgIfBwUNU2lnbmVkIGluIGFzIGRkAgIPDxYCHwMFEi9zaWdub3V0Lz90aGFua3lvdWRkAgEPDxYCHwJoZGQCAg8PZBYEHwUFAzNweB8GBQQxMXB4ZAIDDw8WAh8DBRpodHRwOi8veWVkZGEuY29tL2ZlZWRiYWNrL2RkAgQPDxYCHwMFGmh0dHA6Ly95ZWRkYS5jb20vZmVlZGJhY2svZGQCBg8PFgIfAwURaHR0cDovL3llZGRhLmNvbS9kZAIHDw9kFgQfBQUDM3B4HwYFBDExcHhkAggPDxYCHwMFJ2h0dHA6Ly95ZWRkYS5jb20vcXVlc3Rpb25zL25ldy8%2fZWRpdE5ld2RkAgkPD2QWBB8FBQMzcHgfBgUEMTFweGQCCg8PFgIfAwUwaHR0cDovL3llZGRhLmNvbS9hY3Rpdml0eS9xdWVzdGlvbnMvaW50ZXJlc3RpbmcvZGQCCw8PZBYEHwUFAzNweB8GBQQxMXB4ZAIMDw8WAh8DBRpodHRwOi8veWVkZGEuY29tL2FjdGl2aXR5L2RkAg0PD2QWBB8FBQMzcHgfBgUEMTFweGQCDw8PZBYEHwUFAzNweB8GBQQxMXB4ZAIQD2QWBGYPDxYCHwMFJ2h0dHBzOi8veWVkZGEuY29tL3NpZ251cC8%2fUmV0dXJuVXJsPSUyZmRkAgEPD2QWBB8FBQMzcHgfBgUEMTFweGQCEQ8PFgIfAwUZaHR0cDovL3llZGRhLmNvbS9leHBsb3JlL2RkAhIPD2QWBB8FBQMzcHgfBgUEMTFweGQCEw8PFgIfAwUcaHR0cDovL3llZGRhLmNvbS9jYXRlZ29yaWVzL2RkAhQPFgIfAmhkAgMPDxYCHwAFS2h0dHA6Ly9zdGF0aWMxLnllZGRhY2RuLmNvbS9pbWFnZXMvSGVhZGVyQm90dG9tU2VwYXJhdG9yV2lkZV9ybXQ5YzFkMjJkLmdpZhYEHwUFBTk4MHB4HwYFAzFweGQCAw9kFgICBQ9kFgoCAQ8PFgIfAmhkFgICAQ8PFgIfB2VkZAIDDxYCHwgFDlNpZ25Jbk1haW5MZWZ0FggCAw8PZBYEHwUFBTEwOHB4HwYFBTI0MXB4ZAIJDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAINDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAIRDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAIVDw8WAh8DBQ8vc2lnbmluL2ZvcmdvdC9kZAIZDxYCHwgFD1NpZ25JbkJ1dHRvbkRpdmQCGw9kFgJmD2QWBgIFDxYCHgdvbmNsaWNrBT53aW5kb3cubG9jYXRpb24uaHJlZj0naHR0cHM6Ly95ZWRkYS5jb20vc2lnbnVwLz9SZXR1cm5Vcmw9JTJmJxYGAgEPD2QWBB8FBQMzcHgfBgUEMzlweGQCAw9kFgICAQ8PZBYEHwUFAzJweB8GBQQzOXB4ZAIFDw9kFgQfBQUDNXB4HwYFBDM5cHhkAgcPDxYCHwMFEWh0dHA6Ly95ZWRkYS5jb20vZBYCZg8PZBYEHwUFBDQ4cHgfBgUEMTdweGQCCQ8PZBYEHwUFBTEzMnB4HwYFBDIxcHhkGAcFQmN0bDAwJEZvb3RlckNvbnRyb2wxJEZvb3RlckZvclBhcnRuZXJzMSRNdWx0aXZpZXdGb290ZXJGb3JQYXJ0bmVycw8PZGZkBS1jdGwwMCRIZWFkZXJDb250cm9sMSRNdWx0aVZpZXdDdXN0b21pemFibGVMbkYPD2QCAWQFJGN0bDAwJEZvb3RlckNvbnRyb2wxJE11bHRpVmlld0Zvb3Rlcg8PZGZkBSFjdGwwMCRNYWluJE11bHRpdmlld1NpZ25Jbk1lc3NhZ2UPD2RmZAUeX19Db250cm9sc1JlcXVpcmVQb3N0QmFja0tleV9fFgEFHGN0bDAwJE1haW4kQ2hlY2tCb3hSZW1lYmVyTWUFVWN0bDAwJEZvb3RlckNvbnRyb2wxJExhbmdGb290ZXJDb250cm9sMSRGb290ZXJGb3JQYXJ0bmVyczEkTXVsdGl2aWV3Rm9vdGVyRm9yUGFydG5lcnMPD2QCAWQFHmN0bDAwJE1haW4kTXVsdGlWaWV3U2lnblVwTGluaw8PZGZk%2fUPVGZHkUtr4SaNgdUSGimD1Jjs%3d&%5f%5fEVENTVALIDATION=%2fwEWBQKn6NWJAwKCuJy7DwLJx9%2b1AQLwrpv3BQLQ98K0AkP82WpgsLsvh8xHZ2hCTthPRWRN&ctl00%24Main%24TextBoxSignInUsername=nottellingyou&ctl00%24Main%24TextBoxSignInPassword=tyrewq

There are other hidden inputs that I’m not sending in the args, this is because their values = “”. This wouldn’t be causing the problem would it?

Anyway thanks for taking a look!

Nick

Ok, found something pretty kool. There is a program called Fiddler, it logs all the HTTP requests sent from your computer. Here is what IE POSTS to yedda.com/signin/



POST http://yedda.com/signin/ HTTP/1.1
Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, application/x-ms-application, application/x-ms-xbap, application/vnd.ms-xpsdocument, application/xaml+xml, */*
Referer: http://yedda.com/signin/
Accept-Language: en-us
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; MathPlayer 2.10b; SU 3.011; GTB6.4; (R1 1.6); .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; yie8)
Content-Type: application/x-www-form-urlencoded
Accept-Encoding: gzip, deflate
Host: yedda.com
Content-Length: 3069
Connection: Keep-Alive
Pragma: no-cache
Cookie: ASP.NET_SessionId=cogaky55e1p1l355o2mxgr55; refdata=; yfbi=; testCookie=testCookie

ctl00_ScriptManager_HiddenField=&__EVENTTARGET=&__EVENTARGUMENT=&__VIEWSTATE=%2FwEPDwUKMTc1MDEzNDQxNQ9kFgJmD2QWAgIDD2QWBGYPDxYCHghJbWFnZVVybAUyaHR0cDovL2NzYi55ZWRkYS5jb20vY3N0cmFjay8wLz82MzQwMDkzODIxMDQwNjg3NTAWAh4Fc3R5bGUFDWRpc3BsYXk6bm9uZTtkAgIPZBYEAgEPZBYEAgEPDxYCHgdWaXNpYmxlaGRkAgIPZBYEAgMPZBYCAgEPZBYCAgEPZBYEAgEPDxYCHgtOYXZpZ2F0ZVVybAURaHR0cDovL3llZGRhLmNvbS8WAh4DcmVsBQRob21lFgJmDw8WAh8ABTxodHRwOi8vc3RhdGljMS55ZWRkYWNkbi5jb20vaW1hZ2VzL0xvZ28xMzJYNDZfcm10OWMxZDIyZC5qcGcWBB4Fd2lkdGgFBTEyOXB4HgZoZWlnaHQFBDQ2cHhkAgMPZBYCAgEPFgIeBFRleHQFJVBlb3BsZS48YnIgLz5TaGFyaW5nLjxiciAvPktub3dsZWRnZS5kAgUPZBYEAgEPZBYmZg8PZBYCHgVjbGFzcwUKTG9nb3V0TGluaxYEZg8PFgIfBwUNU2lnbmVkIGluIGFzIGRkAgIPDxYCHwMFEi9zaWdub3V0Lz90aGFua3lvdWRkAgEPDxYCHwJoZGQCAg8PZBYEHwUFAzNweB8GBQQxMXB4ZAIDDw8WAh8DBRpodHRwOi8veWVkZGEuY29tL2ZlZWRiYWNrL2RkAgQPDxYCHwMFGmh0dHA6Ly95ZWRkYS5jb20vZmVlZGJhY2svZGQCBg8PFgIfAwURaHR0cDovL3llZGRhLmNvbS9kZAIHDw9kFgQfBQUDM3B4HwYFBDExcHhkAggPDxYCHwMFJ2h0dHA6Ly95ZWRkYS5jb20vcXVlc3Rpb25zL25ldy8%2FZWRpdE5ld2RkAgkPD2QWBB8FBQMzcHgfBgUEMTFweGQCCg8PFgIfAwUwaHR0cDovL3llZGRhLmNvbS9hY3Rpdml0eS9xdWVzdGlvbnMvaW50ZXJlc3RpbmcvZGQCCw8PZBYEHwUFAzNweB8GBQQxMXB4ZAIMDw8WAh8DBRpodHRwOi8veWVkZGEuY29tL2FjdGl2aXR5L2RkAg0PD2QWBB8FBQMzcHgfBgUEMTFweGQCDw8PZBYEHwUFAzNweB8GBQQxMXB4ZAIQD2QWBGYPDxYCHwMFJ2h0dHBzOi8veWVkZGEuY29tL3NpZ251cC8%2FUmV0dXJuVXJsPSUyZmRkAgEPD2QWBB8FBQMzcHgfBgUEMTFweGQCEQ8PFgIfAwUZaHR0cDovL3llZGRhLmNvbS9leHBsb3JlL2RkAhIPD2QWBB8FBQMzcHgfBgUEMTFweGQCEw8PFgIfAwUcaHR0cDovL3llZGRhLmNvbS9jYXRlZ29yaWVzL2RkAhQPFgIfAmhkAgMPDxYCHwAFS2h0dHA6Ly9zdGF0aWMxLnllZGRhY2RuLmNvbS9pbWFnZXMvSGVhZGVyQm90dG9tU2VwYXJhdG9yV2lkZV9ybXQ5YzFkMjJkLmdpZhYEHwUFBTk4MHB4HwYFAzFweGQCAw9kFgICBQ9kFgoCAQ8PFgIfAmhkFgICAQ8PFgIfB2VkZAIDDxYCHwgFDlNpZ25Jbk1haW5MZWZ0FggCAw8PZBYEHwUFBTEwOHB4HwYFBTI0MXB4ZAIJDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAINDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAIRDw9kFgQfBQUEMTZweB8GBQQxNHB4ZAIVDw8WAh8DBQ8vc2lnbmluL2ZvcmdvdC9kZAIZDxYCHwgFEVNpZ25JbkJ1dHRvbkRpdklFZAIbD2QWAmYPZBYGAgUPFgIeB29uY2xpY2sFPndpbmRvdy5sb2NhdGlvbi5ocmVmPSdodHRwczovL3llZGRhLmNvbS9zaWdudXAvP1JldHVyblVybD0lMmYnFgYCAQ8PZBYEHwUFAzNweB8GBQQzOXB4ZAIDD2QWAgIBDw9kFgQfBQUDMnB4HwYFBDM5cHhkAgUPD2QWBB8FBQM1cHgfBgUEMzlweGQCBw8PFgIfAwURaHR0cDovL3llZGRhLmNvbS9kFgJmDw9kFgQfBQUENDhweB8GBQQxN3B4ZAIJDw9kFgQfBQUFMTMycHgfBgUEMjFweGQYBwVCY3RsMDAkRm9vdGVyQ29udHJvbDEkRm9vdGVyRm9yUGFydG5lcnMxJE11bHRpdmlld0Zvb3RlckZvclBhcnRuZXJzDw9kZmQFLWN0bDAwJEhlYWRlckNvbnRyb2wxJE11bHRpVmlld0N1c3RvbWl6YWJsZUxuRg8PZAIBZAUkY3RsMDAkRm9vdGVyQ29udHJvbDEkTXVsdGlWaWV3Rm9vdGVyDw9kZmQFIWN0bDAwJE1haW4kTXVsdGl2aWV3U2lnbkluTWVzc2FnZQ8PZGZkBR5fX0NvbnRyb2xzUmVxdWlyZVBvc3RCYWNrS2V5X18WAQUcY3RsMDAkTWFpbiRDaGVja0JveFJlbWViZXJNZQVVY3RsMDAkRm9vdGVyQ29udHJvbDEkTGFuZ0Zvb3RlckNvbnRyb2wxJEZvb3RlckZvclBhcnRuZXJzMSRNdWx0aXZpZXdGb290ZXJGb3JQYXJ0bmVycw8PZAIBZAUeY3RsMDAkTWFpbiRNdWx0aVZpZXdTaWduVXBMaW5rDw9kZmTC6bj1UkCe%2BEJB6Qy8yNmM%2FQq9pg%3D%3D&__EVENTVALIDATION=%2FwEWBQKxlZrFAgKCuJy7DwLJx9%2B1AQLwrpv3BQLQ98K0AqTmqzQVwk6DkaqcmOiF06pQf9Cj&ctl00%24Main%24TextBoxSignInUsername=nickpaul.70@gmail.com&ctl00%24Main%24TextBoxSignInPassword=cdcdcd&ctl00%24Main%24ButtonSubmit=Sign+In

So I’m going to try a couple things and then I’ll get back to you with results.

Nick

Haha ok I got it :slight_smile:

Putting the cookies on one line as shown in the post above fixes the problem. Can anyone tell me what happened here? I’ve POSTed forms with cookies on separate lines before with no problems?

Anyway, nice to get a win :smiley:

Nick