Port must be specified apache line 119

I get this error: Port must be specified apache line 119. Every time I try to start apache 2. I know the error is from the config file but I don’t know what I should change line 119 to. Line 119 is: Listen 80. Everything close to it in commented.

Thank you,
Jesse Smith

Hmmmm… found a forum post elsewhere that implied it might be an issue in your NameVirtualHost line. Find that and change it for:

NameVirtualHost 127.0.0.1:80

Obviously, sub in whatever the IP address needs to be - just your machine and 127.0.0.1 is ok. On an internal network at home it’d probably be 192.168.1.XXX. Same in a larger office, or could begin with 172.etc. - or if the machine faces the world then obviously the Internet-facing IP.

Not sure if this will work, but worth a try… :slight_smile:

G

Now I am getting this error:
NameVirtualHost 127.0.0.1:80 has no VirtualHost
I even tried 192.168.0.1:80, still no luck
Thank you,
Jesse

What does you <VirtualHost> say in httpd.conf at the moment?

G

Take a look at this - should help. :slight_smile:

http://httpd.apache.org/docs/vhosts/examples.html

If “Simple” vhosting doesn’t work (which it seems it wasn’t) then try “More complicated name-based” - it’s not really complicated… :slight_smile:

G

See that’s the thing all the vhosting are commented. I’m just using this server for dev (localhost) and I got this error. I can still get localhost to work mySQL, php and all that stuff, but I don’t know how to get rid of the error.

im having the same problem, im on fedora core 3 & its bugging me so much.

Ok, I got it to work now. I don’t really know what I did, but it’s working just fine. sketchynetwk, I would be more then happy to help you out, or greg.harvey could too. Thanks for help.