Port 80 busy problem

hey all, i installed xampp after uninstalling it coz it was showing some problem i restarted n installed xampp but in the end it says port 80 busy.apache could not be started.not even i got IIS. why is this problem happening.how can i see port80 is busy?

Some other software/process is using port 80. If you have lsof on your server, try “lsof -i:80” to find the process and kill it.

You mention IIS, so if it’s a windows host, try this tool http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

i am using my system and xampp is instaled in it. is there anyway i can find whoo is using port 80 on windows vista?

ammark,

IF you failed to uninstall completely (and check via services.msc), then you will have an “extra” Apache occupying port 80 and the second one not properly installed. Uninstall completely and then check services.msc to ensure that there is no Apache (or IIS) running before you reinstall.

Regards,

DK

You could use the following DOS command to list all open ports in a windows system.


netstat -a
OR
netstat -a -n

A quick netstat /? should help you more.

it shows two columns. which one tells the port number. btw the foreign address shows port 80 status s established. how do i get more info/kill that process.

Hello,

The part after the symbol ‘:’ gives the PORT number.
You should get something like IP:PORT in both the columns.

the foreign address shows port 80 status s established. how do i get more info/kill that process.

You could add the switch -o to list the PID of the process and -p TCP to list connections for the protocol TCP. Adding -b or -v may also be useful.


netstat -anop TCP
OR
netstat -anopb TCP

Can’t say how effective is killing a process in windows. However, you could give a try to taskkill or use TaskManager.


taskkill /PID 1234

As always try adding /? at the end of the command you need help with and you will find some option you may be searching for.

Regards

thankx for ur detalied answer but i checked and uninstall n restarted my system n installed again but it says port 80 or 441 that says is busy. i checked but no port on local machine is busy or being showed i even deleted the apache entry in firewall option but still it says port busy whts wrong

Ah! finally after 1 day of installing and uninstalling i found the problem. did little google and found out ppl having skype were having same problem i use oovoo its same as skype. i uinstalled oovoo and installed xampp n its working now. weeeeeeeeeee:lol: thank u guys for ur help:cool:

Hmm… seems strange, not uncommon though:) Killing the application didn’t release the port but uninstalling does?? After all trials… a reinstall or upgrade will only help:lol:

well didn’t killed the app coz i thought killing wuld still assign and keep the 80 port busy(my imagination) anyhow thank God it worked spend whole day uninstall and reinstalling