Plesk permission problem or?

hi guys,
all the while i have been working with client’s webhost running LAMP via Cpanel in linux, and at current im working on a client’s webhost running Plesk in Windows.

The CMS flavor that my client selected for me to work on is Concrete5 (php+mysql).

during the site development i work them on my localhost with WAMP. after completion i uploaded them to my client’s host @ httpdoc/ as the root.

In the Plesk control panel, all the read write permission has been enabled by default. But when i tried to use .htaccess for the SEF URL function, the site showed error “The page cannot be displayed because an internal server error has occurred.” when i tried to load /index.php

When i tried to change the permission say 644, 755, 777 or anything, it wont take effect. the ftp showed “500 ‘SITE CHMOD 777 .htacces’: command not understood”

My question is, is this symptom due to the fact that CHMOD-ding is not allowed in Windows environment or anything else that I might have not known of?

I just wanna make sure that this is the exact problem before firing up an email to their tech support.

Apologise if the question is lame as this is because I am not familiar with Plesk. The settings are abit complecated!

Thanks in advance.

And if you remove the .htaccess it works?
.htaccess looks correct. Has some flaws, but it should work.

yes, it works, but not SEF anymore…the URL becomes /index.php/page and auto update/add plugin from C5’s marketplace does not work anymore. the plugins need to be manually downloaded and then uploaded via FTP.

i made a PHP test by putting php_info.php at the root (httpdoc) and in a folder, say /php/php_info.php. The one at the root works, but the one in the folder doesn’t. plesk is so unfriendly to PHP files, im not sure why.

kindly shed some light. thanks in advance.

And if you remove the .htaccess it works?
.htaccess looks correct. Has some flaws, but it should work.

The error suggests to me that the .htaccess contains an error.
Could you post the .htaccess file and tell us which version of Apache the host is running?

it shouldnt be the case because C5 provided the htaccess for us to copy n paste them in a blank htaccess and upload them.

here is the content:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]