Please help! Totally unable to receive email, boggled :(

Hi! I am having a problem that I have spent hours and hours on. I am totally flumoxed as to why it isn’t working. I am using latest version of nodeworx/siteworx on VPN running interworx.

I can’t receive emails.

My client connects properly, sees the folders…but never sees a message.

Webmail always reports zero messages.

I have tried this on multiple addresses. No matter what, no mail shows up, and no new files appear in the /var/mail/ folders.

I have the permissions set to drwxr-Sr-x. The owner is vpopmail. I also tried setting owner to iworx, no luck.

One other thing. I had been unable to create new mail accounts. I think it was something to do with permissions, because when I set to 777 I could. But now that is fixed when I changed owner and set chmod to drwxr-Sr-x.

I’m desperate. I have spent more than 6 hours scouring the internet and trying everything I can. My whole project is stalled until I can get the email working.

Can anyone shed any light on this?

Sasha Shepherd

Just wanted to say, I figured it out.

I had been migrating from another site. It was another folder on the same VPS node.

So, as root, I had copied the whole user folder in /home/ from one to the other.

This had messed with all the chowns, giving the ownership of everything to root i think.

I thought it might be something like this, and tried to fix it, but I failed.

Success came when i deleted the account, recreated it, and copied only the public_html folder over. Now everything works great :slight_smile:

Great to know, buddhaflow! Sorry no one could help here, but thanks for posting the solution. You never know who else in the future this will help. :slight_smile:

O, and welcome to SitePoint. :slight_smile: