Php 5.3.2 Won't Install On Apache 2.2.15

Hello all, I’m having problem here with php and I can’t figure it out. I have Apache installed on my Ubuntu box and it’s working just fine, but everytime I try to install php 5.3.2 it never finishes the install once I run the make install it shows the libphph5.so in the terminal and it never moves past that point, so is it php or apache or both?