Photoshop CS4 layer select...argh!

In Photoshop CS they had the BEST option for selecting an item on a particular layer. All you had to do was move your cursor over the layer (say Layer 1) in the layers panel, hold down the ctrl key, and right click in order to select the item on that layer.

IS THERE a way to do that in Photoshop CS4? I’ve been dying trying to find it but haven’t found anything. Please help!

Please don’t tell me they got rid of it as that was a huge component of my productivity. I can’t just select the magic wand and select the item. That SUCKS! I don’t want any extra steps - just one! I want my keyboard shortcut back. :frowning:

  • Brian

it’s the same but it has always been CTRL + LEFT CLICK, not RIGHT CLICK, or I never tried right click, but left click still works with CTRL, have you tried??

EDIT: I still have CS3, sorry, I don’t know about CS4

Hello James,

Sorry about that. Left click. But yeah, I use CS3 in college and just upgraded to CS4 at home and that keyboard shortcut is gone on both of them.

On CS4, holding ctrl + left click just selects the layer. Same thing with CS3.

I hate Adobe for getting rid of my most beloved shortcut - it was a big part of my productivity. :frowning:

  • Brian

no, on CS3 CTRL + left click works on selecting (like select tool) the outline of the layer, but you need to click within the little image of the layer, not on the name or elsewhere, right in the tiny image. Try it again CTRL + Click, works for me on CS3

look here, each time I press CTRL and when the mouse cursor is on the tiny image the mouse pointer changes, but not elsewhere than the tiny image:
http://screencast.com/t/kCqU40Ots

James- THANK YOU!!! IT WORKS!!!

No wonder I couldn’t find it - it’s far more restrictive regarding where you can click in CS3/CS4.

THANK YOU!!!

:D:D:D:D:D:D:D:D:D:D

  • Brian

You’re welcome!

I just upgraded to CS4. It’s been driving nuts not being able to select the contents of a layer.

Thanks for the tip!

I am having the same problem, but I don’t know if this applies to the Mac version. Holding the command key (generally has the same functions as ctrl did for PCs) + click doesn’t select. Ideas?? Thanks!