PEAR challenged

Specifically, when in command mode on windows XP, how do I locate the directory I should be in to invoke the $ commands?

(Embarrassed – but I don’t understand the PEAR posts here nor the manual at )

Let me be more specific: The documentation refers to a “pear command line application”. And every command begins with a “$ pear”.

Where do I find this “pear command line application”?

This has got to be basic stuff because ALL THE DOCUMENTATION assumes it’s intuitive.



No, it just indicates that that is not the location of the pear executable on your system.

Apparantly there is a xampp file called xampp_shell.bat that starts a command prompt with the appropriate pear path already set. appears to have all of the details.

If you don’t have the pear location set in the default path, you would do:

[list=1][]Start -> All Programs -> Accessories -> Command Prompt
]C:\Documents and Settings\Owner\> cd \xampp\php\PEAR
[*]C:\xampp\php\PEAR\> pear config-get php_dir

If you do have pear in your default path, you don’t need to perform step 2.

Again, this must be intuitive – but there are no responses so I must not be asking my question correctly;

In one of my PHP/PEAR books is this sentence:

You can check [the configurable location] using the pear command line application:
$ pear config-get php_dir

Given that my PEAR directory is in C:\xampp\php\PEAR in my Windows XP directory and my php modules are in C:\xampp\htdocs\hrf …
Starting with the ‘start’ button, how I do I execute the above $ PEAR command?



Thank you Paul,

I do not have an “Owner” directory within “Documents and Settings”. However, I assume the point is simply to get current on

cd \xampp\php\PEAR

C:\xampp\php\PEAR\> pear config-get php_dir
results in “pear is not recognized as an internal or external command, operable program or batch file”

So I tried C:\xampp\php\PEAR\> $ pear config-get php_dir
results in “$ is not recognized …”

So I tried C:\xampp\php\PEAR\> $pear config-get php_dir
results in “$pear is not recognized …”

I gather that indicates I need to re-install PEAR?


grnadpa Brian