<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8">
    <title>PDO, Array and Superglobal variable $_POST - PHP - SitePoint Forums | Web Development &amp; Design Community</title>
    <meta name="description" content="&amp;lt;?php 
    $alltable = &amp;quot;SHOW TABLES&amp;quot;;
    $statement = $pdo-&amp;gt;prepare($alltable);
    $statement-&amp;gt;execute();
    $result = $statement-&amp;gt;fetchAll(PDO::FETCH_ASSOC);
    // echo &amp;quot;&amp;lt;pre&amp;gt;&amp;quot;;
    // print_r($result); 
    // echo&amp;hellip;">
    <meta name="generator" content="Discourse 2.7.0.beta1 - https://github.com/discourse/discourse version 4c118e4d7ae603eee6a3b2711bc51515eb0c4cca">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#ffffff">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="SitePoint Forums | Web Development &amp; Design Community Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_881fe7c0c89ad703fa1fe6a7cac80c01a59e860b.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_dada489848063cc701f318e3b6ad2943cb264768.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    <!-- Proper Ad Script -->
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/3ea6ceedc3defc7b2344bb8ab6143c942dd5886a.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

  <link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;PDO, Array and Superglobal variable $_POST&#39;" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272.rss" />
    <meta property="og:site_name" content="SitePoint Forums | Web Development &amp; Design Community" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/7/c788fc29c7b91e6bd7c35446e8448913ffe39dd0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/7/c788fc29c7b91e6bd7c35446e8448913ffe39dd0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272/6" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272/6" />
<meta property="og:title" content="PDO, Array and Superglobal variable $_POST" />
<meta name="twitter:title" content="PDO, Array and Superglobal variable $_POST" />
<meta property="og:description" content="New for me. Thanks for your support." />
<meta name="twitter:description" content="New for me. Thanks for your support." />
<meta property="article:published_time" content="2020-12-22T08:50:23+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/9d87c81079e84b2d9c7516aa076acf66e0f80774.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="SitePoint Forums | Web Development &amp; Design Community" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/pdo-array-and-superglobal-variable-post/361272">PDO, Array and Superglobal variable $_POST</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/php/31" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #595986'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>PHP</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272">

            <link itemprop="image" href="https://www.sitepoint.com/community//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/sitepoint/original/3X/c/7/c788fc29c7b91e6bd7c35446e8448913ffe39dd0.png">

          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-12-21T17:42:39Z'>
              <time itemprop='dateModified' datetime='2020-12-21T17:43:36Z' class='post-time'>
                December 21, 2020,  5:43pm
              </time>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <pre><code class="lang-auto">&lt;?php 
    $alltable = "SHOW TABLES";
    $statement = $pdo-&gt;prepare($alltable);
    $statement-&gt;execute();
    $result = $statement-&gt;fetchAll(PDO::FETCH_ASSOC);
    // echo "&lt;pre&gt;";
    // print_r($result); 
    // echo "&lt;/pre&gt;";
    foreach($result as $table) {
    ?&gt;
    &lt;div class="checkbox"&gt;
    &lt;label&gt;&lt;input type="checkbox" class="checkbox_table" name="table[]" value="&lt;?php echo $table["Tables_in_toolcula_apps"]; ?&gt;" /&gt; &lt;?php echo $table["Tables_in_toolcula_apps"]; ?&gt;&lt;/label&gt;
    &lt;/div&gt;
&lt;?php  } ?&gt;
</code></pre>
<p>Hi there,</p>
<p>I have programmatically generated checkboxes based on an array input.<br>
<img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/7/c788fc29c7b91e6bd7c35446e8448913ffe39dd0.png" alt="image" data-base62-sha1="stavlJLUPx0UwfcRvVDkxBZqVq0" width="663" height="498"></p>
<p>Now based on the checkboxes ticked I was looking around the way in which superglobal variable $_POST can hold those elements, which are actually table values from the database.</p>
<pre><code class="lang-auto">I wanted to do some operation here:
    if (isset($_POST['download'])) {
      foreach ($_POST['download'] as $table) {
        echo "Yes"."&lt;br /&gt;";
      }
    }
</code></pre>
<p>But this gives error:<br>
<code>      foreach ($_POST['download'] as $table) {</code></p>
<p><strong>Warning</strong> : Invalid argument supplied for foreach() in <strong>/home1/…/pdo_back_up_option.php</strong> on line <strong>18</strong></p>
<p>Once the <code>checkboxes</code> are ticked doesn’t the superglobal variable <code>$_POST</code> holds the values in an array?</p>
        </div>

        <meta itemprop='headline' content='PDO, Array and Superglobal variable $_POST'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="3" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/droopsnoot'><span itemprop='name'>droopsnoot</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-12-21T18:08:23Z'>
              <time itemprop='dateModified' datetime='2020-12-21T18:09:30Z' class='post-time'>
                December 21, 2020,  6:09pm
              </time>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="codeispoetry" data-post="1" data-topic="361272">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/codeispoetry/40/69169_2.png" class="avatar"> codeispoetry:</div>
<blockquote>
<p>Once the <code>checkboxes</code> are ticked doesn’t the superglobal variable <code>$_POST</code> holds the values in an array?</p>
</blockquote>
</aside>
<p>What does it show you, when you display the contents of the <code>$_POST</code> array? Does that give any clues as to why the error occurs?</p>
<p>Does this line give any clue as to why it might be failing?</p>
<pre><code class="lang-auto">&lt;label&gt;&lt;input type="checkbox" class="checkbox_table" name="table[]" value="&lt;?php echo $table["Tables_in_toolcula_apps"]; ?&gt;" /&gt; &lt;?php echo $table["Tables_in_toolcula_apps"]; ?&gt;&lt;/label&gt;
</code></pre>
        </div>

        <meta itemprop='headline' content='PDO, Array and Superglobal variable $_POST'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-12-21T18:15:16Z' class='post-time'>
                December 21, 2020,  6:15pm
              </time>
              <meta itemprop='dateModified' content='2020-12-21T18:15:16Z'>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="droopsnoot" data-post="2" data-topic="361272">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/droopsnoot/40/61779_2.png" class="avatar"> droopsnoot:</div>
<blockquote>
<p>Does this line give any clue as to why it might be failing?</p>
<pre><code class="lang-auto">
</code></pre>
</blockquote>
</aside>
<p>I realized my knowledge gap:<br>
this helped:<br>
</p><aside class="onebox allowlistedgeneric">
  <header class="source">
      <a href="http://learningaboutelectronics.com/Articles/How-to-retrieve-data-from-an-array-of-check-boxes-with-PHP.php#selection" target="_blank" rel="noopener nofollow ugc">learningaboutelectronics.com</a>
  </header>
  <article class="onebox-body">
    <img src="" class="thumbnail" width="20" height="20">

<h3><a href="http://learningaboutelectronics.com/Articles/How-to-retrieve-data-from-an-array-of-check-boxes-with-PHP.php#selection" target="_blank" rel="noopener nofollow ugc">How to Retrieve Data From an Array of Checkboxes In PHP</a></h3>



  </article>
  <div class="onebox-metadata">
    
    
  </div>
  <div style="clear: both"></div>
</aside>

<p>I think we have to pick up from <code>name=table[]</code></p>
        </div>

        <meta itemprop='headline' content='PDO, Array and Superglobal variable $_POST'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Pepster64'><span itemprop='name'>Pepster64</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-12-21T20:23:02Z' class='post-time'>
                December 21, 2020,  8:23pm
              </time>
              <meta itemprop='dateModified' content='2020-12-21T20:23:02Z'>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="codeispoetry" data-post="1" data-topic="361272">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/codeispoetry/40/69169_2.png" class="avatar"> codeispoetry:</div>
<blockquote>
<pre><code class="lang-auto">    $alltable = "SHOW TABLES";
    $statement = $pdo-&gt;prepare($alltable);
    $statement-&gt;execute();
    $result = $statement-&gt;fetchAll(PDO::FETCH_ASSOC);
</code></pre>
</blockquote>
</aside>
<pre><code class="lang-auto">This might help:

$sql = "SHOW TABLES in burroughsFarms"; // Just Testing out on my Database:
$stmt = $pdo-&gt;prepare($sql);
$stmt-&gt;execute();

$tables = $stmt-&gt;fetchAll(PDO::FETCH_COLUMN);

echo "&lt;pre&gt;" . print_r($tables, 1) . "&lt;/pre&gt;";

foreach ($tables as $table) {
    echo $table . "&lt;br&gt;";
}
</code></pre>
        </div>

        <meta itemprop='headline' content='PDO, Array and Superglobal variable $_POST'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="2" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Pepster64'><span itemprop='name'>Pepster64</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-12-21T21:32:04Z'>
              <time itemprop='dateModified' datetime='2020-12-21T21:35:36Z' class='post-time'>
                December 21, 2020,  9:35pm
              </time>
          <span itemprop='position'>#5</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="codeispoetry" data-post="1" data-topic="361272">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/codeispoetry/40/69169_2.png" class="avatar"> codeispoetry:</div>
<blockquote>
<pre><code class="lang-auto">    &lt;div class="checkbox"&gt;
    &lt;label&gt;&lt;input type="checkbox" class="checkbox_table" name="table[]" value="&lt;?php echo $table["Tables_in_toolcula_apps"]; ?&gt;" /&gt; &lt;?php echo $table["Tables_in_toolcula_apps"]; ?&gt;&lt;/label&gt;
    &lt;/div&gt;
</code></pre>
</blockquote>
</aside>
<p>I was bored so I did a little more:</p>
<pre><code class="lang-auto">$db = DB::getInstance();
$pdo = $db-&gt;getConnection();

/* The Above is just my connection string and there is no CSS and hardly any HTML */

$sql = "SHOW TABLES in burroughsFarms"; // Just Testing out on my Database:
$stmt = $pdo-&gt;prepare($sql);
$stmt-&gt;execute();

$tables = $stmt-&gt;fetchAll(PDO::FETCH_COLUMN);

$submit = (htmlspecialchars($_POST['submit'] ?? null));

if ($submit === 'submit') {
    $tables = $_POST['tables'];
    echo "&lt;pre&gt;" . print_r($tables, 1) . "&lt;/pre&gt;";
}
?&gt;
&lt;form class="tables" method="post" action="tables.php"&gt;
    &lt;?php foreach ($tables as $table) { ?&gt;
        &lt;label&gt;&lt;input type="checkbox" class="checkbox_table" name="tables[]" value="&lt;?= $table ?&gt;" &gt;&lt;?= $table ?&gt;&lt;/label&gt;
    &lt;?php } ?&gt;
    &lt;button type="submit" name="submit" value="submit"&gt;Submit&lt;/button&gt;
&lt;/form&gt;
</code></pre>
<p>There’s a small glitch in the script, but I let you figure it out. Beside I think it would make you better understand it.</p>
        </div>

        <meta itemprop='headline' content='PDO, Array and Superglobal variable $_POST'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-12-22T08:50:23Z'>
              <time itemprop='dateModified' datetime='2020-12-22T09:00:35Z' class='post-time'>
                December 22, 2020,  9:00am
              </time>
          <span itemprop='position'>#6</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="Pepster64" data-post="5" data-topic="361272">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/pepster64/40/40486_2.png" class="avatar"> Pepster64:</div>
<blockquote>
<pre><code class="lang-auto">$db = DB::getInstance();
$pdo = $db-&gt;getConnection();
</code></pre>
</blockquote>
</aside>
<p>New for me. Thanks for your support.</p>
        </div>

        <meta itemprop='headline' content='PDO, Array and Superglobal variable $_POST'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/codeispoetry'><span itemprop='name'>codeispoetry</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/pdo-array-and-superglobal-variable-post/361272">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-12-22T09:00:17Z' class='post-time'>
                December 22, 2020,  9:00am
              </time>
              <meta itemprop='dateModified' content='2020-12-22T09:00:17Z'>
          <span itemprop='position'>#7</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="Pepster64" data-post="4" data-topic="361272">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/pepster64/40/40486_2.png" class="avatar"> Pepster64:</div>
<blockquote>
<p><code>($tables, 1)</code></p>
</blockquote>
</aside>
<p>True or False not 1.</p>
        </div>

        <meta itemprop='headline' content='PDO, Array and Superglobal variable $_POST'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <!-- BSA Ad Script -->
<!--
<script>
    (function(){
        var bsaScript = document.createElement('script');
        bsaScript.type = 'text/javascript';
        bsaScript.async = true;
        bsaScript.src =  "https://cdn-s2s.buysellads.net/pub/sitepoint.js?" + (new Date() - (new Date() % 600000));
        document.getElementsByTagName('head')[0].appendChild(bsaScript);
    })();
</script>
-->
<!-- Proper -->
<!--
<div id="footer-ad-spacer"></div>
<div id="footer-ad" class="proper-ad-unit ad-sticky">
    <div id="proper-ad-sitepoint_main_1">
        <script> 
            propertag && propertag.cmd.push(function() { proper_display('sitepoint_main_1'); });
        </script>
    </div>
</div>
-->
  </body>
  
</html>
