Outlined text in Firefox 3.6

I have no idea where to post this, but I can’t seem to find a good answer. Since I downloaded Firefox 3.6 on my Mac OSX.4 PPC, some of the text renders outlined and hallow. This includes my username on Twitter and many other examples. I’ve attached a screenshot to show what I’m seeing. Has anyone else noticed this? Is there some strange setting I have enabled? Pretty bizarre.

I’m running FF, Safari v4.04, and Opera v 10.10. Firefox is the only effected browser. See attached.

Ok… could you post a screenshot of the twitter page?

This is only FF on the mac or also Safari? Do you have any other browsers running on your Mac?

It may be that the CSS on those sites was there all along, and now you suddenly have a browser capable of seeing it?

In the big purple text, do you see a black stroke? On Linux, I can only see the stroke on Chrome and Epiphany… FF doesn’t show it. Opera, Konqueror and FF show the shadow background on the second example, while Epiphany shows the stroke but not the shadow!

Alternately, you could post the CSS on the Twitter page or whichever pages you’ve seen this on, to verify that this is the case.

That’s the weird thing, there’s no special CSS going on at all. I checked every instance of it I could find, and I didn’t see anything out of the ordinary. The twitter example is below. It doesn’t seem to be connected to any one element either.

#side #me_name {
font:bold 1.2em/1.2em Helvetica Neue,Helvetica,sans-serif;

#me_name {

Can you post a link to the test page? Kinda hard blindfolded lol :slight_smile:

What is ‘Helvetica Neue’ is that supposed to be two fonts (Helvetica, Neue) or one (“Helvetica Neue”) ?

Helvetica Neue is, in fact, 1 font, and I do have it installed on my computer. However, that seems to be what’s rendering weird. When I change the font, or simply get rid of the Neue, it goes back to normal. Is anyone else experiencing this?

Did you understand my cryptic question; I really meant fix the CSS line to which one was appropriate (I now know in your case it was one font):

font : bold 1.2em/1.2em "Helvetica Neue", Helvetica, sans-serif;

Family names containing whitespace should be quoted. If quoting is omitted, any whitespace characters before and after the name are ignored and any sequence of whitespace characters inside the name is converted to a single space.

Does that solve the rendering issue now?

It still doesn’t explain why a new version of FF on a Mac would outline the text due to a CSS error. I mean, wouldn’t lots of people be experiencing this, if Twitter has such craptastic code? AFAIK, this is a pretty common CSS error (not quoting font families with spaces). Why just this poor guy getting the weirdo text?

In case it wasn’t clear, this isn’t a problem with the OP’s code; this is a problem with large public websites like Twitter. Unless he’s gonna write his own stylesheet, why should he have to fix Twitter’s code (and why is he and only he getting the strange effect)?

Maybe has a “weirdo font” (could be corrupt) or on his system; it is matching something else in that family? Else maybe the font rendering-engine in said browser has been changed.

This is certainly weird. After looking at my enabled fonts, I didn’t have the exact match (Helvetica Neue) enabled, but had many other versions in the family enabled (i.e. Helvetica Neue 55…etc). Once I turned it on, restarted my browser and computer, there was still no change.

Also, it is much more than simply Twitter. This site has the main body font as Helvetica Neue, in quotes, and still has the same result.

I am quite stumped right now. I think I should contact Mozilla and see what they have to say about it. I can’t be the ONLY person this is happening to…right?

No, you’d think there’s someone out there experiencing this, but when I originally googled I didn’t run into anything, other than, FF destroying sites with PNGs with their “colour correction” (your is one of the OSes where my site looks like a 5 year old had a colour party with it with newer FF).

Mozilla’s gonna want to assume it’s something in your OS (which may have been laying dormant and the newest FF brought it out).

I suppose you could also delete all your fonts and reinstall from good sources?

If someone else with newest FF on a Mac could confirm it’s NOT all Macs with new FF?

I have FF3.6 on a new imac and it looks fine. Maybe there is a corrupt or somehow mismatched font on the system.

Have a look here as a user mentions a problem with helvetica that was cured by switching on/off the font with font book (and other similar problems).

I fixed the problem with one of two ways. First, I deactivated all of the million OpenType faces of Helvetica Neue I had and reactivated all of the TrueType. Second, I cleared my system font cache and restarted my computer. I’m not sure which one did it (I’m thinking the cache clearing as I did have the plain “Helvetica Neue” truetype activated with no conflicting OT). In any event, thanks for the help!

No problem, and now no “weirdo font” rendering - glad you found a solution.

you’re not the only one… I have tried searching for this unusual “phenomenon” for the last year, on and off, on google as well, and was very surprised that I did not come across any post on this.
Seems like you’ve achieved some success in this. I’m always afraid to trash things on my computer, just in case I trash something important.
Could you outline exactly what you did, to get rid of the outlined text I keep seeing, popping up on websites, increasingly so (might I add).
I’m also on a mac, and I’m on Safari. It doesn’t matter which browser I use… I still see the outlined text. And I do have Helvetica Neue installed on my computer.
Thanks in advance!


It seems that original poster has not been around for a while so you may not get a response.

There seems to be a problem with Helvetica as documented here:


The solution seems to be delete any old Helvetica fonts on the system or to turn them on and off with font book. Sorry, I can’t offer any specifics.

But, if googling for “delete deactivate fonts mac” doesn’t bring anything, try the MacRumors forums.

I have also been looking for this “phenomenon” on and off, online, but could never find much information on it. It’s really weird! It doesn’t just happen with Firefox, but with all the other browsers as well –*Safari, Chrome, Opera.

I have an iMac, as well as a MacBookPro. Both are displaying these weird Helvetica fonts for about 2 years now, and it’s increasingly infuriating as I’m getting it more and more on a lot of the websites.

I can’t trash my Helvetica fonts as I’m a graphic designer. I need these fonts…
Can anyone recommend any solutions?

It’s really strange that i can’t google a solution… for the last 2 years I might add. :frowning: