OS X Clock Screwed Up

The clock on my MacBook OS X 10.5.8 will not automatically update.

I set it to last year while rendering some music to get an old timestamp, and when I click the “Update Automatically” (or whatever) it doesn’t work.

I rebooted, but no luck.

I tried re-setting the PRAM, but no luck.

I tried this article, but no luck.

Just when I stopped hating my MacBook, the hate-affair is back again…

(Macs do NOT “just work”. What a load of crapola.) :mad:

Any help would be appreciated!!!

TomTees

there seems to be other people having the same problem

http://www.google.co.uk/search?q=os+x+set+time+date+automatically+problems

http://discussions.info.apple.com/message.jspa?messageID=9418780
http://discussions.info.apple.com/message.jspa?messageID=9442988

didn’t read fully enough to see if there is actually an answer but maybe there’s something in there that’ll be helpful

What difference would that make?

I am staying in a motel currently, but have full Internet access and seem to have a good connection, so Internet connectivity shouldn’t be an issue.

TomTees

Does it show correct in the Mac version of a PC’s BIOS?

if you have a firewall of some sort, try turning it off temporarily to see if that makes a difference. if it does you’re a step closer to sorting it.

If I go under “Security”, “Firewall”, and then switch from “Allow only essential services” to “Allow all incoming connections” it didn’t do anything to help the clock situation.

Unless maybe I need to “lock” things and then re-boot?

(This problem is turning out to be a real bugger?!) :mad:

TomTees

How would I check that? :confused:

TomTees

Is there any risk that running the Disk_Utilities app could screw up my MacBook?? :confused:

Do I need to back anything up first?

TomTees

so far as i know it gets the correct current date and time (that is what we’re talking about isn’t it?) from the internet. so a firewall may be blocking something. quick way to find out is to turn off the software firewall if one is running and then see if it’s able to update the time and date. worth a go seeing as it’d only take a minute to try.

I tried it twice with a re-boot after each attempt.

It didn’t help.

My system clock absolutely will not update when I click “Set dtae & time automatically”.

I had this issue after I got my new MacBook a year or two ago, but it seemed to go away after a re-boot.

But this has been broken all week. :frowning:

TomTees

Try repairing your permissions (/Utilities/Disk Utility.app)