Nothing displaying in IE9?

this works okay in firefox 10 and in IE 8 but in IE 9 all I am seeing is one border, thats all.

I’m really struggling to debug this. Any assistance would be appreciated. If you can see an error if you have any recomendations on steps to correct this would be helpful - rather than just telling me that there is an error please :slight_smile:

The site is based on the latest version of Worpress.

it has been suggested that there is a javascript library clash. I have disabled all wordpress plugins, but still I cannot see anything in IE. (see screenshot below)

IE is turning on compatibility mode, but even it I turn it off I get the same thing

I’ve tried this on IE 9 on my laptop and my desktop and just see what is shown in the screenshot below. I’m not sure why I see this, yet other people in the comments are saying that they don’t have an issue with IE9? (I have IE verson, update versions: 9.0.4 (KB261844).

I’m quite stuck on what to do to fix this?

Image attached of what I am seeing - I have cleared my cache and still having this issue.

Hm, works absolutely fine for me in IE9. Is it still not working for you?

Yip. A total fail for me in IE9 on my laptop and my desktop. I can’t think of anything that is different about either of these computers that would mean it isn’t working for me - but is working for everyone else? That just seems too weird?

Any recommendations on things that I could check to try to diagnose the issue?
I have installed IETester and this shows that it works fine in IE7 and IE8, but shows a blank screen for IE9 or IE10. Very confusing. I’m used to errors where the layout is messed up - but never had an issue where nothing is displayed!

Yes, very odd, but I can’t see what might be causing a problem. The page validates fine, so that’s not it. Weird that it’s not working for you on two computers. Presumably you’ve refreshed the browsers / cleared the cache etc? Worth a try, anyhow. Beyond that, someone more savvy will have to step in and help!

Yes I’ve cleared the cache on both computers. I have access to another desktop and another laptop. I’ll try on these as well. Just is concerning to know that for some people they might see a blank screen!

It’s because IE9 will default to Document Mode: IE7 Standards (Oh, why do I hate IE?).

If you click F12 you’ll get the developer tools palet and you can see what the site looks like with IE7/8/9. In 8 and 9 it looks pretty good. IE7 darn near crashes the browser.

So, to fix the issue on IE8 & IE9 (IE8 will also default to IE7 Standards :headbang:) you’ll need to add a special IE meta tag at the top of the markup as close to the opening <head> tag as possible. It is as follows:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

Give that a whirl :smiley:


Thanks for the tips - this sounds like it should be the answer to all my problems, but I’m not sure that it is :frowning:
I hit F12 and changes all the settings through IE 7, 8 and 9 - but doing that made no difference (I saw the blank page for all of them, regardless of what document mode was set.

Using IETester, I do see the correct webpage for IE7 and IE8 though.

I’ve added the meta tag you suggested to the site, as this seems to be a good idea.

This is confusing. I really don’t get why my browser is being weird.
Were you able to replicate the issue by changing the settings? a lot of other people have told me that they don’t see the problems in IE9?

When I first tried it, it crashed my browser so I restarted it and hit F12 to see what it was showing me. I could get it to render in IE7 Standards but the links didn’t work and the alignment of the page was out of whack. If I throw it into Quirks Document mode all I get is a white page with a single black horizontal rule. IE8 it works and IE9 it works.

Try clearing the cache, closing the browser and opening it one more time. I had to do that with mine just now before it actually paid attention to the meta edge directive you installed.


No joy. Using the F12 developer tools I can get the site to display a white page with the one border in quirks mode. With any other setting my browser is just showing a black page. It seems to lag and not even refresh unless i resize the window. something funky going on I think.

Hmmmm… I’m at a loss to what’s going on then. I’ve looked at it in WinXP IE8 as well as IE9 on Vista Home and Win7 Ultimate. It looks great in all three now that you have the meta tag installed.

If it were just wonky on the one machine I would thing it was an anomaly but I think you said it was showing up strangely on two machines running IE9. I can’t explain it. Perhaps someone else can help here.

@awasson - thanks for your assistance. I have another 2 machines that I can try this on - will give that a go tonight and see what happens there. Thanks for your help.

Sounds good… Definitely pop back and let us know what you see in the other machines.

Tested another computer last night with IE9 - exact same issue. very weird. Why is it that all the computers I’m trying aren’t working, yet other people are saying that they can get it to work?

Yeah, I don’t understand it either. Check the source (view source) from the browser to see if the meta tag you added is applied.

I’m currently looking at it on IE 9.0.8112.16421IC Update Version: 9.0.4 on an entry level 3 year old Toshiba Laptop running Vista Home Premium SP2

My machines are all on Windows 7 (one on enterprise, one on ultimate and another on home premium).
Could be something to do with windows 7? Although I’d be surprised if that were the case?

I don’t think so… I’ve also looked at on Windows 7 Ultimate and it looks fine there too.

I’ve now moved this to a new server, and I’m still seeing the same problems.

really stuck on this one? HELP!

published on now…

Did you mean to say clear the main cache? I’ve tried that and always get the same results (across 3 different computers).

What do you mean by “Don’t forget to using border attribute to have a clear visual.” What border attribute? and a clear visual of what specifically?

It loaded fine for me using Win7 and the same version of IE9 as you - except my update version is 9.0.5

View-source looks OK?