Need Help: Submit Button is not working

Hi Folks,
This is Sujan & I’m brand new to this forum. I’m facing a problem here. That’s why I need your help. Please go to this URL http://spot1marketing.com/index.php & have a look to Request A Quote form(upper right corner). The submit image is not working here. I couldn’t be able to find why that is happening.

Please help me by fixing this problem. Thanks in advance…

Welcome to the SP forums.

I’ve moved your question to the javascript forum, because I saw that you use javascript on that button. Let’s see if someone here can help you out.

Thanks Guido, I was pretty confused about where to say this. You put this into right place.

I wonder if this is a PHP issue, as it looks like a form that is processed by PHP (but I’m only guessing here). There is JS involved, but is that for submitting the form or just checking the input before sending? Do you have a PHP script for processing this form? Normally there will be a link to it inside the action quotes here:

<form name=“form1” id=“frmindex” method=“post” action=“” >

So in your code file, what is between those quotes, if anything?

Thanks for your reply Ralph, I’ve added the PHP file name into the action quote. But still it’s not working. As it should be fixed urgently, that’s why I want to bother you again. I’m attaching the index.php and requestaquote.php file. Please when you get time, have a look & give me a solution. Please please please…

Did you write this code yourself? That requestaquote.php file is basically another web page, which is not what you want. I’ll move this to the PHP forum, as this is not my area.

Just tried the form on your website, and it seems to work? I entered some test data, and then it took me to the requestacode page, and it shows the “Email sent successfully” message.

By the way, those tiny red dots that appear to the right of not/wrongly filled in form fields are really very very small (and I don’t know if everybody will understand their meaning?).

Form still doesn’t work for me.
I looked at your html source code, you have one <form> tag, but two closing </form> tags.
May be causing the problem?

Ralph, you are right. I’ve not written this. That’s why I couldn’t be able to understand this properly…But I’ve to fix it urgently.

But Guido, why this is not working for my turn. I’m pretty confused and little bit bothered with this. Will I able to fix it urgently…?

If this is critical, it’s best either to learn how to do it yourself or pay someone who does know how to do it. It’s a bit hit-and-miss what you will get in a forum. One option might be to use a service like Wufoo.