MySQL Password - Can't Set One - Assistance Please

Okay, so, I recently started reading the PHP/SQL book – I had everything installed with WAMP from a class I tried to take a few years ago, so I didn’t bother re-installing the software.

When I got to the point in the book where he explains how to change the root user password, I did of course try it, however it did not work. I didn’t think anything of it (since I figured that it would work properly on whatever web server I’d be using). Well, now that I’m a smidge further in the book, I’ve realized that I should really get a password set for that thing.

I’ve already done a search of the forums, tried the things suggested, and nothing has worked so far – maybe this is something stupid and simple like my usual issues, but I am not understanding what I’m doing wrong.

Any/all help would be greatly appreciated! :sick:

Thanks, I will try it (I’m anticipating it will work, since this looks totally different from anything else I’ve found). :slight_smile:

The command showing in your screenshot is meant to be run from the command line. Not from within the mysql command line program.

In the mysql command line program you need to execute a SET PASSWORD query