<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8">
    <title>Modal links not working - General Web Dev - The SitePoint Forums</title>
    <meta name="description" content="Hi again, 
I am having a issue with modals and jquery. Below is the modal html code: 
&amp;lt;div class=&amp;quot;bg-modal-welcome&amp;quot;&amp;gt;
    &amp;lt;div class=&amp;quot;modal-content-welcome&amp;quot;&amp;gt;
        &amp;lt;img class=&amp;quot;startpic&amp;quot; src=&amp;quot;../img/SG-Register-Start.jpg&amp;hellip;">
    <meta name="generator" content="Discourse 2.4.0.beta10 - https://github.com/discourse/discourse version b6765aac4b532c026418a7ffd9effd0741ab8a37">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#ffffff">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="http://www.sitepoint.com/community/t/modal-links-not-working/348329" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"http://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"http://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="http://www.sitepoint.com/community/opensearch.xml" title="The SitePoint Forums Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_d48665bcb943ebbb3f04f99dad246cc3bda72e67.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_69f95d49ee5aafc4a9571ffd086d884bdf872fe0.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    




<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/3ea6ceedc3defc7b2344bb8ab6143c942dd5886a.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

<link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-f35b4da49411e6f5559073523aab983da483976a3954c79c756f8579f6fbd6ef.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-f35b4da49411e6f5559073523aab983da483976a3954c79c756f8579f6fbd6ef.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Modal links not working&#39;" href="https://www.sitepoint.com/community/t/modal-links-not-working/348329.rss" />
    <meta property="og:site_name" content="The SitePoint Forums" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="http://www.sitepoint.com/community/t/modal-links-not-working/348329/7" />
<meta name="twitter:url" content="http://www.sitepoint.com/community/t/modal-links-not-working/348329/7" />
<meta property="og:title" content="Modal links not working" />
<meta name="twitter:title" content="Modal links not working" />
<meta property="og:description" content="Perhaps you can share with the class, so that anyone who comes later might benefit from your solution?" />
<meta name="twitter:description" content="Perhaps you can share with the class, so that anyone who comes later might benefit from your solution?" />
<meta property="article:published_time" content="2020-02-18T11:57:04+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/f00b24c64d832481ce09a67edddad31db5dad44a.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="The SitePoint Forums" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <h1 class="crawler-topic-title">
    <a href="/community/t/modal-links-not-working/348329">Modal links not working</a>
  </h1>

  <div id="breadcrumbs" itemscope itemtype="http://schema.org/BreadcrumbList">
      <div itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
        <a href="http://www.sitepoint.com/community/community/c/general-web-dev" class="badge-wrapper bullet" itemprop="item">
          <span class="badge-category-bg"></span>
          <span class="category-title" itemprop="name">General Web Dev</span>
        </a>
        <meta itemprop="position" content="1" />
      </div>
  </div>

      <div class='crawler-tags-list' itemscope itemtype='http://schema.org/DiscussionForumPosting'>
          <div itemprop='keywords'>
            <a href='http://www.sitepoint.com/community/tag/jquery' rel="tag">
              <span itemprop='headline'>jquery</span>
            </a>
          </div>
      </div>

  


    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='http://www.sitepoint.com/community/u/magnusmikkels1'><span itemprop='name'>magnusmikkels1</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-02-17T17:38:53Z'>
              <time itemprop='dateModified' datetime='2020-02-17T17:46:08Z' class='post-time'>
                February 17, 2020,  5:46pm
              </time>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi again,</p>
<p>I am having a issue with modals and jquery. Below is the modal html code:</p>
<pre><code class="lang-auto">&lt;div class="bg-modal-welcome"&gt;
    &lt;div class="modal-content-welcome"&gt;
        &lt;img class="startpic" src="../img/SG-Register-Start.jpg" alt=""&gt;
        &lt;div class="stitle row"&gt;
            &lt;div class="col l6 offset-l3"&gt;
                &lt;p class="center starttitle newfont2"&gt;Velkommen til Study Guider&lt;/p&gt;
            &lt;/div&gt;
        &lt;/div&gt;
        &lt;div class="nextcontainer"&gt;
            &lt;p class="nextbutton center white-text"&gt;Neste&lt;/p&gt;
        &lt;/div&gt;
    &lt;/div&gt;
&lt;/div&gt;
</code></pre>
<p>Modal css code:</p>
<pre><code class="lang-auto">.bg-modal-welcome{
width:100%;
height: 100vh;
position: fixed;
top: 0;
background-color:rgba(0,0,0, 0.7);
justify-content: center;
align-items: center;
&lt;?php if(isset($_SESSION['username'])) : ?&gt;
    &lt;?php if(isset($_SESSION['username3'])) : ?&gt;
        display: none;
    &lt;?php else : ?&gt;
        display: flex;
    &lt;?php endif; ?&gt;
&lt;?php else : ?&gt;
    display: none;
&lt;?php endif; ?&gt;
}
.modal-content-welcome{
position: relative;
width: 400px;
height: 600px;
background-color: white;
border-radius: 10px;
padding: 5px
}
.startpic{
position: relative;
width: 390px;
height: 590px;
background-color: white;
border-radius: 10px;
}
.starttitle{
position: relative;
color: white;
font-size: 22px;
}
.stitle{
position: relative;
bottom: 23vw;
}
.nextbutton{
font-size: 18px;
}
</code></pre>
<p>And finally my jquery code:</p>
<pre><code class="lang-auto">document.querySelector('.nextcontainer').addEventListener('click', function () {
            document.querySelector('.bg-modal-welcome').style.display = 'none';
            document.querySelector('.bg-modal-picture').style.display = 'flex';
        });
</code></pre>
<p>My problem is that the jquery will not work when the modal is displayed when page loads. I know the code is not wrong though, as it works if the modal is opened with the click of a button on the page. Then everything works how it is. I was wondering what I may be missing or what other approach I need to do if I want it to work like I want.</p>
<p>Additional information of why I have coded it like I have:<br>
This modal is supposed to pop up if the users just registered. I do this by checking if they have uploaded a profile picture by checking if their name is in the profilepicture database. If it cannot find it ($_SESSION[‘username3’]) the modal will load when page opens. This is when the click jquery function is not working. I tested it to work if a button gets it to pop up and it did. Thank you for any help.</p>
        </div>

        <meta itemprop='headline' content='Modal links not working'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>


    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='http://www.sitepoint.com/community/u/m_hutley'><span itemprop='name'>m_hutley</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-02-17T23:37:22Z' class='post-time'>
                February 17, 2020, 11:37pm
              </time>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="magnusmikkels1" data-post="1" data-topic="348329">
<div class="title">
<div class="quote-controls"></div>
<img alt width="20" height="20" src="https://avatars.discourse.org/v4/letter/m/3ec8ea/40.png" class="avatar"> magnusmikkels1:</div>
<blockquote>
<p>the jquery</p>
</blockquote>
</aside>
<p>Nothing you are doing here is jQuery. That Javascript is entirely vanilla.</p>
<aside class="quote no-group" data-username="magnusmikkels1" data-post="1" data-topic="348329">
<div class="title">
<div class="quote-controls"></div>
<img alt width="20" height="20" src="https://avatars.discourse.org/v4/letter/m/3ec8ea/40.png" class="avatar"> magnusmikkels1:</div>
<blockquote>
<p>when the modal is displayed when page loads. I know the code is not wrong though, as it works if the modal is opened with the click of a button on the page.</p>
</blockquote>
</aside>
<p>So what code do you use to determine if the modal is displayed or not?</p>
        </div>

        <meta itemprop='headline' content='Modal links not working'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>


    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='http://www.sitepoint.com/community/u/magnusmikkels1'><span itemprop='name'>magnusmikkels1</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-02-18T00:43:34Z'>
              <time itemprop='dateModified' datetime='2020-02-18T00:48:18Z' class='post-time'>
                February 18, 2020, 12:48am
              </time>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Oh my bad, bad with what language is what. And for the question the css dude…</p>
        </div>

        <meta itemprop='headline' content='Modal links not working'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>


    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='http://www.sitepoint.com/community/u/magnusmikkels1'><span itemprop='name'>magnusmikkels1</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-02-18T01:51:48Z' class='post-time'>
                February 18, 2020,  1:51am
              </time>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I found a solution that works. Still confused why what I had did not work though.</p>
        </div>

        <meta itemprop='headline' content='Modal links not working'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>


    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='http://www.sitepoint.com/community/u/m_hutley'><span itemprop='name'>m_hutley</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-02-18T11:57:04Z' class='post-time'>
                February 18, 2020, 11:57am
              </time>
          <span itemprop='position'>#7</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Perhaps you can share with the class, so that anyone who comes later might benefit from your solution?</p>
        </div>

        <meta itemprop='headline' content='Modal links not working'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>


    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='http://www.sitepoint.com/community/u/magnusmikkels1'><span itemprop='name'>magnusmikkels1</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-02-18T12:15:24Z' class='post-time'>
                February 18, 2020, 12:15pm
              </time>
          <span itemprop='position'>#8</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Well I changed the div containing the button to have a onclick=“function()”. Then the function doing what I wanted. My bad for doing a less efficient method, but should have worked from orginal method.</p>
        </div>

        <meta itemprop='headline' content='Modal links not working'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>


    </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav' itemscope itemtype='http://schema.org/SiteNavigationElement'>
        <ul>
        <li itemprop="name"><a href='/community/' itemprop="url">Home </a></li>
        <li itemprop="name"><a href='/community/categories' itemprop="url">Categories </a></li>
        <li itemprop="name"><a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a></li>
        <li itemprop="name"><a href='/community/tos' itemprop="url">Terms of Service </a></li>
        <li itemprop="name"><a href='/community/privacy' itemprop="url">Privacy Policy </a></li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <div class="proper-ad-unit ad-sticky">
   <div id="proper-ad-sitepoint_main_1">
       
    </div>
</div>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/6eb9df8882b2f1244b8786b2692d281653a9fcfb.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
