Menus in wordpress

I didn’t think I messed with the top menu

that top menu popped up, it goes away if I add this to the CSS

#top-navigation nav {
  display: none;

But how can I make it not show up at all?

You have about 50 CSS stylesheets. Could you please tell us what file has that rule? Because it’s not being applied.

I had it turned off/on for a little bit.
its now set to display: none though.
the rule is at the bottom of
but im looking to turn it off from the worrpress admin area (and not via CSS)
Id think it would be in the menu area but thats only a guess

I duplicated it on the dev server

I dont want the top links

<div id="top-navigation">
<ul class="nav">
<li class="current_page_item"><a href="">Home</a></li>
<lii class="page_item page-item-724"><a href="">About</a></li>

So Im guessing its a menu of some sort, but heres my menu section

Where are those links coming from (so I can turn them off)

That top menu is your secondary menu, and it seems to be the active menu. The primary menu seems to not exist. The page menu you do have, is that a widget that displays categories you are using?

You should have menu options on the left in Customize, where you can choose menu. Depending on the theme, more menu options can be elsewhere. like in Manage Locations.

I think you have to deactivate that second menu, maybe by create and activate the primary menu. Of course, if you wish you can delete the buttons in the secondary menu or maybe delete that whole menu. It can easily be recreated.

I seldom use Wordpress so I can be wrong where to find everything. Your images was a good help, thanks!

thanks eric, your right, heres that customize thing

but look what happens when I make those changes

But look what happens when I try to take that bottom menu off

That is confusing also, cause I only have the one menu

Sorry for the delay, waited for a more knowledgeable member to step in. I’m not a regular WP user.

It seems like you kept the secondary menu. That secondary menu I think can also work as a footer menu, is that what you have?

As you use that as a main menu, I would try replace it with the regular main menu given the same buttons.

Though usually the main menus have a mandatory “home button” for the comment feed you can’t deactivate in the menu, but I think that it can be inactivated by the startpage option on the left in your screenshots.

Post how it goes.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.