MDaemon SMTP Error... Probably DNS Related

Hey all, I have a question about an error I am getting in MDaemon. From what I have read around the net, it appears to be a DNS misconfiguration on my end, but I am not sure exactly where the problem is at.

Mon 2006-09-25 19:51:14: Session 7033; child 1
Mon 2006-09-25 19:50:53: Parsing Message <c:\mdaemon\remoteq\pd50000000897.msg>
Mon 2006-09-25 19:50:53: From: an_email@address.com
Mon 2006-09-25 19:50:53: To: an_email@address.com
Mon 2006-09-25 19:50:53: Subject: Email Subject
Mon 2006-09-25 19:50:53: Message-ID: <102630.1159238136876.JavaMail.SYSTEM@server>
Mon 2006-09-25 19:50:53: MX-record resolution of [verizon.net] in progress (DNS Server: 66.96.80.194)…
Mon 2006-09-25 19:50:53: P=000 D=verizon.net TTL=(0) MX=[relay.verizon.net]
Mon 2006-09-25 19:50:53: Attempting MX: P=000 D=verizon.net TTL=(0) MX=[relay.verizon.net]
Mon 2006-09-25 19:50:53: Attempting SMTP connection to [relay.verizon.net : 25]
Mon 2006-09-25 19:50:53: A-record resolution of [relay.verizon.net] in progress (DNS Server: 66.96.80.194)…
Mon 2006-09-25 19:50:53: D=relay.verizon.net TTL=(55) A=[206.46.232.11]
Mon 2006-09-25 19:50:53: Attempting SMTP connection to [206.46.232.11 : 25]
Mon 2006-09-25 19:50:53: Waiting for socket connection…
Mon 2006-09-25 19:51:14: Winsock Error 10060 The connection timed out.
Mon 2006-09-25 19:51:14: This message is 15 minutes old; it has 45 minutes left in this queue
Mon 2006-09-25 19:51:14: SMTP session terminated (Bytes in/out: 0/0)

I have altered the email address and subject lines, but the rest of the info remains unaltered. It keeps trying to resend, but never makes it through. The email is going from a local account on my mail server to a remote computer hosting verizon email addresses.

Any help on fixing this problem would be greatly appreciated!

Well whats the domain name so we can chekc the dns?

Well everything checks out fine for the DNS stuff in nslookup. Can you try another smtp server?

The problem appears to be universal. It doesn’t like any remote server.

Can you ping the servers from that specific server?

Hmmm… odd. The DNS server it connects to pings fine, but the SMTP server IP its trying to connect to seems to be down. I tried it from my remote server and my house, same scenario for both locations.

Its Verizon… I’ve had problems with this for a while and I’ve contacted their support department several times.

At first I thought it was a problem of reverse DNS, PTR records, MX protocols, etc…

Now I’m convinced that Verizon is the devil of SMTP communications.

Have you gotten past this?