max_execution_time and set_time_limit

Hi,

I have set a max_execution_time of 60 for one of my domains.
Since I have some long running cron-scripts, like newsletter mails, I need more time.

Thus I tried to set a set_time_limit(120) in my script newsletter.php. But for some reason the script still stopps after 60 seconds with following error message:

Maximum execution time of 60 seconds exceeded in <b>/path/rewrite.php</b> on line <b>687</b>

Now, the error message refers to a different script, that is included with include_once…

Why does the set_time_limit not apply to the included rewrite.php when I set it for newsletter.php???

Regards
Florian

if you don’t know how much time your script will take use this code…

max_execution_time(0);

But setting max_execution_time would be globaly set for the domain. This I don’t want.
I only want this one script, called as cron, to have a different execution time!

Regards
Flözen

use the function only on the page where you want…

it will work for that particular page only…

What PHP Version are you referring to???

there is no function

max_execution_time(0); 

yet…

This is only a runtime configuration!

sorry i have used wrong word function…

you can change the configuration on run time for a particular page…

I tried that before with

ini_set(“max_execution_time”, 0);

on the far top of the script. But it did not seem to effect anything…
(Local value for saft_mode is OFF!)

?!?!?!?

Regards
Flözen