Many days of frustrations: xampp apache won't start on win 7 Help please

:frowning: Can anyone of you wiz help ms please? It’s been 5 days since I’m trying to get apache to work on my laptop win 7.
I want to proceed in learning Joomla so bad but this *+%#} is holding me back, I follow few advices but nothing works: disable Skype, reboot etc:

Urgent help.
Thank you.

Hi Jahmikes and welcome to the forums. :slight_smile:

I’ve moved your question to the Apache forum, as you’re likely to get a better response there.

I had similar problems and downloaded and installed the Lite version. It worked first time:

Try running TCPview:[URL=“”]

It will show all the applications running and what ports they are using.

Look down the list and see what application is using local port 80.

much thanks.

Here is what I found, C:\Program Files\HP\HP Photosmart 5510 series\Bin\HPNetworkCommunicator.exe

Ok! I found out that my wireless printer is using up part 80, what and how should I fix this so apache can work?

This is really crazy or it must be me, I give up, i guess there’re no solutions for windows 7!!

I don’t use Windows so I can’t help, but have you read the sticky at the top of the forum? There’s a lot of information in that.

No but I guess I will, Thnk you.


Did yo try the Xampp Portable Lite Version?


I’ve been through loading Apache, PHP, MySQL, etc on a Windows box for years. My move from XP to 7, however, was quite painful as I had to learn the hard way NOT to load in Window’s protected directories (Program Files is one such directory).

I’ve also learned NOT to use “snapshot” canned programs to load my set of daemons but have had great success mimicing my online server on my test server using Kevin Yank’s free Chapter 1 - Installation. The only thing he didn’t say in early versions of his book was that you need to STOP (and prevent automatic start on Windows load) the IIS server. Unfortunatly, you’ve replaced IIS with your printer so you’ll need to force it to look for another port (or assign 8080).

With all that as a preface, (1) load MySQL using the installer (it can be placed in the default Program Files directory), (2) load Apache 2.2+ into an unprotected directory (I created a separate partition for all my web work to facilitate backup and restore - use localhost as the server name and as the IP Address) then unzip PHP into another unprotected directory (again, I did this on my separate partition). You can then load PHPMyAdmin into another unprotected directory.

You’ll be able to edit all the appropriate files without interference by Windows - except C:\Windows\system32\drivers\etc\hosts which you’ll have to edit as the Administrator in order to use local virtual hosts.

John_B - oh, so true! Unfortunately, my brain shut down so many years ago I think it’s atrophied!



Thank you DK but I’m an ordinary guy just wanting to learn joomla and I can’t imagine I’ve spent so many days including all of yesterday and night just to get one crappy thing to work. Apache or xampp should update there software to be able to allow novices like me not to waste days just to get one thing to run…this is some bs.
Anyway DK can you please break it down step by step for me, most of what you instructed are jargons to me.
Here is what I’ve done so far:
Changed listening from 80 to 8080, and 443 to 4499 and back to 4430, disabled Blanchcashe, turned off windows fire wall, disable u a c. What else can I possibly do, I’m not one to give up easily but damn am I the stupidest guy trying to learn joomla?
Please break it down and help me if you can.
I am really waiting.

Have you tried the web platform installer? That will hook up joomla, drupal, wordpress and lots of other open source CMS packages. Actually will run on IIS not Apache but that is pretty immaterial these days.

No I haven’t but how can I is and how to proceed and what should I do with all the xampp downloads?

By the way folks feel free to help, if you had this problem but had gotten it solved.


This is a complex, technical question so some basic jargon MUST be used. It’s not to talk over anyone’s head, only the standard identification of critical features which a webmaster must be familiar with.

Learn Joomla? It’s a canned CMS (Content Management System) which you control from a backend (Joomla’s control panel). All that’s required is that you can install it on a server (there are hosts like WebHostingBuzz which provide Specialist Hosting packages which are tailored to the higher loads Joomla - and other CMSs - require).

For your test server, though, you’ve unsuccessfully attempted to install a canned program for the “snapshot” of server tools (Apache, MySQL and PHP). I believe that the problem with the installation is that port 80 was in use by another application (I’m shocked that a printer would capture port 80 but Skype is known to do that, too).

While I “don’t believe in” canned server sets like XAMPP, I fear that you’ll be unable to install individual daemons even with the help of Kevin Yank’s book (the FREE Chapter 1 which covers installation across many different systems).

  1. UNinstall your XAMPP- you’ll need to reinstall when port 80 is available.

  2. Use services.msc to STOP any service which reports to be using port 80.

  3. REinstall XAMPP. The things that you need to be aware of are that the server’s name should be “localhost” (w/o quotes) and the IP Address should be (by definition, the IP address for localhost, i.e., your computer).

XAMPP will have a directory where you MUST place the “website” you want to test. I’ll not go into virtual hosts as that’s a more advanced topic. Just install Joomla in the directory XAMPP specifies (normally htdocs or public_html or www or …).

Since you’re claiming to be a novice, may I recommend Kevin Yank’s book: Build Your Own Database Driven Web Site. It was a good place to learn PHP and setting up a test server is where the book started - WELL WORTH THE TIME AND EFFORT and now in its fourth edition.



If you set up the wireless printer manually without HP’s auto-configure (junk) software, you shouldn’t need this running.

If you do, turn it off, fire up XAMPP first, then the network communicator after that. It should be able to find another port to use.

This is a much easier avenue to pursue than attempting to reconfigure apache for the first time.


With Apache, er, XAMPP configured on god know what, it’d be easier (IMHO) to start over again and do it right! That said, you’re spot on recommending that the wireless printer NOT use port 80 (shut it down, REinstall XAMPP, then let the printer find a usable port).



Web Platform Installer is easy – do a google search, click on results, follow onscreen instructions.