MAMP problem: Since Mountain Lion, all I'm seeing is "It works!"

I just upgraded to Mountain Lion and have 2 problems:

  1. Any web site that I’m running simply shows this:

When obviously it isn’t working

  1. Virtual directories that I previously set up to be in a Dropbox folder (so that I can keep developing sites across different machines) are being flagged as invalid directories:

I am running the latest version of MAMP (2.1.1)

I’ve seen some posts about various config options that I might need to change in Mountain Lion, but I always thought that the key benefit of running MAMP was that it protected you from significant changes that happen in the shipped versions of Apache/MySql/PHP; everything should be self-contained, right?

Anyway, would appreciate some advice on this. Cos at the moment, my dev environment is not working one bit.

[I have a backup plan - I have a second laptop that is set up to run MAMP using these Dropbox locations, and that machine is still on Lion, deliberately, as I knew this might be an issue!]


WinDoze has a server configuration file named httpd.conf and a virtual host configuration file named extras/httpd-vhosts.conf (both in Apache’s config directory) and WinDoze uses its hosts (extensionless) file to point to the httpd-vhosts.conf so you can use some local directory (other than Apache’s htdocs). While I’m not a fan of “canned programmes,” I’d recommend that you check your equivalent of those three files. If this is a new install, you’ll likely have to deal with the httpd-vhosts.conf and hosts files to setup your local domain directories (use the sample code in those files as guidelines).

If you still have a problem, go ask Kevin as I understand that he’s now recommending “canned programmes” in the latest edition of his book and is, from what I understand, a Mac user (I’m not).



He is a Mac user and so I shall go bother him :slight_smile:

I haven’t seen too many people reporting problems with MAMP. Might be a ‘just me’ thing :frowning:


Pretty much just had the same problem, I disabled the in-built apache:

sudo apachectl stop

Works for me


First, WELCOME to SitePoint!

Mac uses a built-in Apache? Well, they certainly got that right! Not sure about being able to actually load/start duplicate Apache services, though, nor which will actually get stopped with that line.



Hi Ian,

As @richaskew said,
It sounds like it’s the default Apache server is enabled and hijacking the requests to localhost.
You can disable “Web Sharing” under system preferences to disable the Apache server that ships with mac os.

By jove, I think he’s got it …

That worked for me too, although I had to mess around with the port settings. Annoyingly I can’t remember exactly which change sorted all the problems, because after running the sudo command it didn’t work straight away. Weird. Anyway, all working now. Thanks Rich.

No problem, and they’ve removed Web Sharing from the Mountain Lion system preferences which doesn’t help.