Major Text Issues

Hi all,

I have done something very wrong, but am not sure what exactly. Would really appreciate if someone could point me in the right direction!

This page: http://juh.pelli.co.uk/

My problem is with the text, none of the text for me is selectable (tested on Mac Firefox and Safari). The links show no cursor pointer on hover either.

Can anyone spot what I have done wrong? Is it something to do with the z-index?

Really appreciate any help.

Thank you :slight_smile:

Si

It is the z-index values I have set. I have removed these and it fixes the text issues.

See following link: http://juh.pelli.co.uk/2/

Previous still works to show old CSS code with the z-indexes in place: http://juh.pelli.co.uk/

But I am unsure how to move the content up and behind the arrows.

Can anyone help with that?

Go back to what you did, but don’t give the whole rest of the page a -20 z-index. Just set it a number lower than the strip is set to.

I don’t mess with negative z-indices if I can avoid it, partially because Firefox had? a bug where a negative z-index moved that element behind the body, making it invisible.
So if the strip is 20, set the rest to 5 or something.

Also you can use a negative top margin instead of a positioned negative top. Which may prevent any weird positioning bugs.

Thank you very much :slight_smile:

As suggested above, in screen.css, if you change all the z-index:-20 to z-index:2 and all the z-index:-10 to z-index:1, the problem will go away.

Thanks, Allan, I hadn’t seen the -10 one.