Mail that comes through the contact form shows “WordPress” as its sender name. How can I change this?

I am using Contact Form 7 version (4.7) in Wordpress (x*****t is my host)
Email works, I get all the information.
The problem is the “from line” in the email says
From “WordPress” and when I open the email and expand on the from in the email the whole line reads:
WordPress x*****t@example.com

In the settings under the mail tab in the plugin the from definition looks like this:
FROM x*****t@example.com

My email account under my cPanel has the following:
x*****t@example.x*****t.com

In the cPanel when I try to define and email account that definition looks like this:
Email _____________ @ example.x*****t.com

Question how do I fix the from subject so it read x*****t and not WordPress?

Thank You

Have you looked at this: https://contactform7.com/faq/mail-that-comes-through-the-contact-form-shows-wordpress-as-its-sender-name/

2 Likes

Yes I have

I will try to post a file of the things I have done.

Hi,

If you look at the page @Gandalf linked to, you see that you also need to type in a “Sender Name”. Missing the plain name will get you the “WordPress” inserted as the name.

ContactForm7.com:

If you want to use another name so that “WordPress” no longer appears as your sender name, you must explicitly set the sender name in the From field in the Mail section as the following:

I do think it is that easy. :slight_smile:

2 Likes

Have tried that and it does not work

Did you type it like (with your example): X*****T <x*****t@example.x*****t.com> including the email standard LT and GT signs?

Yes!

But what you posted was not at all the same formatting as in the ContactForm7 image!

That should be in this standard email address field format: x*****t <x*****t@example.com>, just like the example in that image.

My email account under my cPanel has the following: xt@example.xt.com

That is a whole different address, and probably the account address has no room for the plain sender name.

In the cPanel when I try to define and email account that definition looks like this:Email_____________ @ example.x*****t.com

Whatever that example means, there can’t be a space after the at sign in a valid address.

Question how do I fix the from subject so it read x*****t and not WordPress?

Probably by going through all fields for your email address that the ContactForm7 plugin deals with and assure your plain sender name is not omitted where it is supposed to be in a correct typed name and email address.

Hope you can solve the issue. :slight_smile:

Whatever that example means, there can’t be a space after the at sign in a valid address.

Sorry about that, When I copied the information into the document a space got into the address.
The document has been updated.

Good Catch:smiley:

1 Like

We have an answer

This is what the folks over at the vistapanel said to me.
I am also hosting at x10hosting and using their free account:

"Free hosting email can only be sent and received via the Webmail in your free hosting cPanel.
php mail() sendmail is enabled on free hosting and it allows the sending of Forum activation links and similar type of mails, any emails which are not registration activation emails or similar may not be delivered by PHPsendmail.
sorry smtp is not available on free accounts … but you may send via your own SMTP server using PHP sendmail/mail()

free hosting email is provided as is, and on a best effort basis.
please see:
http://kb.ifastnet.com/index.php?/article/AA-00201/0/Email-on-free-hosting.html

If need a more reliable mail service, then get more out of e-mail with our Premium Hosting plans featuring POP, IMAP, SMTP and much more including the industry leading Cpanel"

For those of you who continue to have trouble and are hosting at x10hosting I suggest you go over to the
vistapanel website and create a support ticket
This is only for free accounts(issue)

Well unless there are no more questions then I am closing this post out

Closed as of 4-9-2017 – JDG

Hi,

How does that explain anything regarding the sender name?

Your original problem was:

Have you really tried to properly add your own sender name when sending emails?
Like the email address standard: x*****t <x*****t@example.x*****t.com>

1 Like

I have created two email address under my cpanel
In wordpress in the plugin
When I try to save either email address I get the following error message:
Sender email address does not belong to the site domain
The save is in the contact form under the mail tab
I can only save the name in the from line <x*****t@j***********55.byethost14.com>
which is the hosting account name with out an error and if I put a name in front, I get no email at all.
I believe under the free x10hosting you only get “WordPress” in the subject line by default.
What is being said in the previous post you need SMTP server

Off Topic

@jperson: please read the FAQs, specifically

Keep personal information private. All posts in the forums are easily found via search engines, so unless you’re willing to expose your information to the world, please do not post telephone numbers, e-mail addresses etc in your posts.

This is the reason we have been obscuring your e-mail addresses. If you’re happy to post them in full and leave them exposed to Spambots, that’s up to you.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.