Loader not retaining dimensions

hey everyone,

I’ve created a movie clip that in turn loads x amount of people’s profiles into a 10x10 grid.

This works great 95% of the time where it loads a movie that is 50x50.

For some reason, the remainder 5% of the time, it will load the movie at the full size of the image (200x200).

Under tracing, the width/height returns as 10050 in normal situations and 10200 under the rest.

I’ve tried setting the width and height of both the movie, loader and loader.content, all of which fail to resize the image.

Has anyone ever come across this before?

Cheers

Gavin

Anyone?

Are you setting the width and height after the load is complete or before ?

I’ve tried both?! That said, the nature in which i am doing it might have something to do with it.

I have an image preloader that preloads the image and then on the complete event, it sets the loader contentPath to the actual image path that was preloaded.

I then also tried setting the dimensions then.

Is there an load complete event for the loader?

Cheers

Gav

Lol well I resolved that issue but in turn it came with a price.

Although I can’t replicate this on my own computer, when ever I set the width/height after the loader as completed, it prevents the image from showing.

If I remove the code that sets the width/height, it makes them huge.

We’ve tried uninstalling and reinstalling the flash player with no success.

What’s weird is that this only happens in IE. Sods law, every one “important” knows you should use IE and not one of those other browsers :wink:

Did you try setting the width and height in the event handler for Event.COMPLETE event ? If you are using AS3 that is.

Yup as above, the code worked (although had the issue where the images would open at their full size and not the size I wanted them to) when I removed the line that set the width/height on complete.

We tested it on a number of computers and it appeared to be local to one user, so we’re assuming it’s an issue with his computer.

Thanks anyway mate! Much appreciated!

Gav