Libc.so.6 version

Hi!
Ha anybody ever tried to upload a PHP extension to a shared host? I have a shared hosting plan with godaddy.com, and I’m getting the following error message:
“/lib/libc.so.6: version `GLIBC_2.8’ not found (required by ext/libglib-2.0.so)”.

I think it’s about time to upgrade the Linux server. Does anybody have an idea what I can do until then?

That to me looks like you’ve uploaded a module compiled on one Linux distro to another - so its been built against a different version of the core libraries - best is finding out what the godaddy server is and actually getting a module for that distro itself.

I tried branding the ‘.so’ with freebsd-brandelf for CentOS 4 or 5, but it still didn’t work. “libc” is a preloaded library I cannot override.

Yes, you don’t want to be overwriting libc, that’ll potentially make a monumental mess of the system and break it.

The answer is, you need to find the correct php extension, built for your platform.

I think Godaddy does not support PECL.HostGator does.

PECL should be supported, would be an odd choice not to completely.