Latest Linux experiance

I have to set up a raspberry Pi with linux and it is getting me so FRUSTRATED! It is also not helping as I am in a confined location but the hardware that the Pi is connected to can not be moved.

I suppose if I knew what I was doing it would be Ok but I am learning again - the reasons for giving up with it before are coming back to me.

Some examples ( from memory as it was a few hours ago ) but not all the problems I have had.

Example 1:
Create a file and try to save it into the www folder - I can not open file, I get an error. What do you mean I just want to save the file. Consult a co worker and am told I have to do it by opening leafpad as an administrator.

Example 2: download a file to www but it is not there. Look around for it and its in the download folder even though I asked for it to be saved in the www folder. Check Google and I have to move it using terminal as the administrator as I can not drag and drop or copy and paste.

Example 3: Open the first file change it and try saving it but again I am not allowed to. Open leafpad as administrator; edit and save.

Decide to login as administrator but I do not know the password; I assume I have to set up a user. Co worker nearly has a heart attack when I tell him I want to login as administrator. Told I need to check what group I am in - I might be Pi - let that group access the www folder.

Gave up and went and did something else.

I don’t have much more than newbie experience with Linux.

But the “run as administrator” is a Windows thing too.

I can’t say how much Linux is like Windows, but I’ve noticed it seems to be necessary when working with files directly under C:/

Windows has what is to me rather complex and confusing Security measures in place.
At least I don’t understand the “Group” permissions configurations well enough to go messing with them.

But I have found that if I put my “work” under C:/users/…/documents/ that I rarely experience permission problems.

I know if I spent more time setting up Linux it would probably work how I want. I used the same process when installing windows and would have not had any problems moving or creating files.

I run Windows as an admin and to be honest the command line is more secure than it used to be as certain things I do with it I now have to run as admin. Whereas in other Windows versions I didn’t have to.

Are you able to use FileZilla to view the Raspberry PI?

I use Linux to drag and drop a LocalHost project to the Online Server. By default folder file permissions are transferred as 0755 and need changing to 0777 otherwise files will not save.

Using FileZilla to change the Online folder permissions is achieved by right-clicking on the Online folder and setting the file permission to 0777. It is recommended to precede the numeric Octal number with a zero.

777 ?
That seems even more evil than 666 :japanese_ogre:

I mean, let anything do anything?

I’d be reluctant to use anything that required those permissions and if I absolutely needed to I’d be sure to change them back to something more secure immediately


:} :slight_smile: :slight_smile:

I am in the process of generating and saving SVG files and have tried combinations other than 0777 without success. I will try to temporarily only use 0777 before saving the file and afterwards revert to a safer option.

1 Like

You don’t need a special setup for this I think. :smile:

To access the folder and files as admin just run your file manager as admin/superuser and open the file with it. You then also can drag and drop as you please. Mind the resulting permissions though and set as appropriate.
sudo nautilus

Nautilus for Ubuntu, or Nemo, Dolphin, Caja, Thunar, Xfe, Krusader, 4Pane. :wink:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.