Keyboard and touchpad don't work

A hardware question. This morning my laptop started up ok, but neither mouse nor keyboard work. So I shut it down the hard way, and started up again, no improvement.
I attached an external mouse, and that works. So I’m sure if I attach an external keyboard too, that would work as well (but I don’t have one atm to test it).

Not a very practical solution for a laptop though, can’t travel around with all that external stuff.

Anyone has an idea what the reason might be, and how to solve it?

I’ve googled around a bit, and found videos for replacing the keyboard, forum posts talking about checking KB/TP connections (where?), but in this case both stopped working at the same time, so it shouldn’t be a faulty keyboard/touchpad, and it would be just my bad luck if two connectors loosened up at the same time.

It’s a Samsung R530.

Thanks for any tips you can give me.

Have you tried starting your laptop in safe mode? If it works in safe mode but not in normal mode, maybe re-installing the drivers will help. And make sure that you anti-virus is up to date so you can run a check, just in case

Yes I tried safe mode. No difference.
My antivirus is up-to-date, gonna run a check now just to be sure.

Try updating the drivers anyway. I doubt it is going to be that but this is easier that opening the laptop itself. It could be hardware failure but laptops are a pain to fix.

Also, check if you could restore its state to a date where it worked fine just in case that some update has messed up with the drivers or configuration.

1 Like

I’ll do that as soon as the scan is completed.

Ehm, how do I do that? It’s been years since a computer failed on me, I don’t remember. I’m running W7

I agree with @molona, it looks like a drivers problem. I’ve had similar issue with touchpad on my laptop. And this has been fixed after reinstalling Windows

Read this:

1 Like

Ok I’ll definitely reinstall the drivers. The fact both of them stopped working at the same moment had me wondering.

Scan is at 5% after 1 hour, I’ll have to have some patience.


Great. The antivirus found 3 infected files, got rid of them, asked to reboot, and during reboot the battery went dead (I didn’t notice the power was disconnected…).

Now all I get is a black screen :frowning:

Off Topic:

Perhaps your laptop is suggesting you need a holiday?


I sure will need one once this is resolved. Right now startup repair is running.

1 Like

Ok it’s up&running again. Too bad this extra problem didn’t solve my keyboard/touchpad problems :wink:

Before I do anything else, I’m gonna backup my data. Looks like that’ll take an hour or two.

I’ll be back :smiley:


So although I’ve never heard of this, but make sure there isn’t a keyboard combination/switch to deactivate the keyboard and touchpad. I know there is typically a function key combination to disable the touchpad (I’ve never heard of one to disable the keyboard).

Do you by chance use a docking station? Does the laptop still think it is docked?

Never heard of that. Will have to check it.


I sure hope not :wink:

What make and model number is the laptop?

Is there anything flagged up in Device Manager?

Samsung R530

Yes I checked the driver status, and on both was the dreaded yellow triangle. Windows register messed up (that figures).
So I tried to reinstall them, no luck.

So now I’m doing a system restore from 4 days ago (most recent restore point available). I didn’t do anything spectacular in these 4 days anyway, so if it works I should be good. Keeping my fingers crossed.

And I backed up all my data :smiley:

Haha! We all knew that already! :stuck_out_tongue_closed_eyes:


Incredible. System restore failed because “impossible to access a file”. I disabled the antivirus and tried again. Still the same error :frowning:

Edit: it seems it didn’t remember I disabled the antivirus after reboot, maybe part of the system restore did work… :confused:

Third restore failed as well, and this time the antivirus wasn’t active. I have no idea what else to do :frowning:

Edit: doing a restore from a system image :sweat:

Restoring from a system image did the trick, fortunately. After almost eight hours, keyboard and touch pad are working again :sweat_smile:

Thanks to all for the help


Until whatever patch/driver gets updated again :where is the taped mouth smiley?: