<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>jQuery is string styled - #4 by system - JavaScript - SitePoint Forums | Web Development &amp; Design Community</title>
    <meta name="description" content="Hi friends. Let’s say you search for a string of text in your HTML. I have also consider there may be multiple occurrences of the same string. I would like to know can jQuery be used to tell if this string is styled. Wha&amp;hellip;">
    <meta name="generator" content="Discourse 2.8.0.beta10 - https://github.com/discourse/discourse version a407d4298441ab60dc8c175e0669b85b8628f8b4">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#3a3a3a">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/jquery-is-string-styled/376419" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="SitePoint Forums | Web Development &amp; Design Community Search">

      <link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_aae37ef1d4546f9556bcfd3e64ac917c59359e76.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop"  />
      <link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_521_0b9c75388d7573cb5cad04cf1f6808ffd045f8d8.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="521" data-theme-name="nav links component"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_515_65e591e42f19ae330b876218517f0f5b6dff3e54.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="515" data-theme-name="header"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_518_5ec0272e6635771330f6f5f2ef3ddaffe826f204.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="518" data-theme-name="hide buttons on review page"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_522_d8ebfd500c053dae8566622195e6d9a56d34e449.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="522" data-theme-name="post styling (underline links, prevent avatars from sticking)"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_514_3e86bcf81849bf826dec3649bf1f209fc31b5cda.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="514" data-theme-name="signup"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_516_f6430c1fdd4194e6dd77b7ed7641360b144be0ee.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="516" data-theme-name="signup - onboard"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_517_45f8d756e57bf44841e4018151cb68e31d7434d0.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="517" data-theme-name="signup - set password"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_513_94b298153f0c723e592e0a1def6000a72f262c85.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="513" data-theme-name="sp ads"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_519_0176931ddad65fac8deba1ba5ed7c1f186188a35.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="519" data-theme-name="staff name colors"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_512_40e2dc3c50153d10e4ceaa7f85368dff3168ebee.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="512" data-theme-name="topic post"/>
<link href="https://sea2.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_511_a75eecc6247c8412cdfb4fb51c93efe56f2d7b91.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="511" data-theme-name="sitepoint"/>
    <!-- Proper Ad Script -->
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/6ef07837143d5fffd5fe4a7ddece907ed3758b1b.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-signup" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <h3 class="title"></h3>
    <div class="content-body">
      <div>
        <ul class="description"></ul>
        <label class="label-login"></label>
      </div>
      <form name="signup-form" id="signup-form" action="">
        <label class="error"></label>
        <input type="hidden" name="origin" value="community">
        <input type="text" name="username" placeholder="Username" required="">
        <input type="email" name="email" placeholder="Email" required="">
        <button class=" btn" type="submit"></button></form>
      
    </div>
    <div class="content-footer">
      <label class="label-social"></label>
      <div class="login-social"></div>
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/84c383874314c29a12824432b578dc9ec26ebfd2.js?__ws=www.sitepoint.com"></script>
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/12e8f1330bb2863428049315a91dd1bffef56849.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-onboard" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <div>
      <h3></h3>
      <p></p>
    </div>
    <div class="sp-modal__cover-container">
      <img class="sp-modal__cover" src="">
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/572fe22f3412926aca181dadbfa2d886f41f2ac0.js?__ws=www.sitepoint.com"></script>
<div id="sp-modal-set-password" class="sp-modal hidden" style="display: none;">
  <div class="sp-modal__overlay"></div>
  <div class="sp-modal__content">
    <h3></h3>
    <div>
      <p></p>
      <form name="set-password-form" id="set-password-form" action="" method="POST">
        <label class="error"></label>
        <input type="password" name="password" placeholder="Password" required="" minlength="10" pattern="(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).*">
        <label class="requirements"></label>
        <button class="btn" type="submit"></button></form>
      
    </div>
    <button title="close" class="sp-close-modal"></button>
  </div>

  
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/00c03d9db1444f140c4a7e1847872155e4ec327d.js?__ws=www.sitepoint.com"></script>
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/bf19ff40fa9b3dffffada79ed67e9dd75d410132.js?__ws=www.sitepoint.com"></script>

<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/6962ee34197c5bcbce2f55a7e37b7f5bfbebf4b6.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

  <link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-v3-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;jQuery is string styled&#39;" href="https://www.sitepoint.com/community/t/jquery-is-string-styled/376419.rss" />
    <meta property="og:site_name" content="SitePoint Forums | Web Development &amp; Design Community" />
<meta property="og:type" content="website" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/jquery-is-string-styled/376419/4" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/jquery-is-string-styled/376419/4" />
<meta property="og:title" content="jQuery is string styled" />
<meta name="twitter:title" content="jQuery is string styled" />
<meta property="og:description" content="This topic was automatically closed 91 days after the last reply. New replies are no longer allowed." />
<meta name="twitter:description" content="This topic was automatically closed 91 days after the last reply. New replies are no longer allowed." />
<meta property="article:published_time" content="2022-01-19T23:38:02+00:00" />
<meta property="og:ignore_canonical" content="true" />


    
  </head>
  <body class="crawler">
    
<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/fc4409811f1414056992ba3c59c61c7a42675242.js?__ws=www.sitepoint.com"></script>
<link href="https://fonts.googleapis.com/css?family=Roboto&amp;display=swap" rel="stylesheet">


<script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/375663796349b60db60a837aa565d4b10840bbdd.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg" alt="SitePoint Forums | Web Development &amp; Design Community" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/jquery-is-string-styled/376419">jQuery is string styled</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/javascript/33" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #d3a604'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>JavaScript</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

      <div class="topic-category">
        <div class='discourse-tags list-tags'>
            <a href='https://www.sitepoint.com/community/tag/jquery' class='discourse-tag' rel="tag">jquery</a>
        </div>
      </div>
  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/philhagen'><span itemprop='name'>philhagen</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/jquery-is-string-styled/376419">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-10-16T16:36:41Z' class='post-time'>
                October 16, 2021,  4:36pm
              </time>
              <meta itemprop='dateModified' content='2021-10-16T18:26:20Z'>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi friends. Let’s say you search for a string of text in your HTML. I have also consider there may be multiple occurrences of the same string. I would like to know can jQuery be used to tell if this string is styled. What I mean by styled is color and <code>&lt;em&gt;, &lt;strong&gt;, &lt;span&gt;</code> tag wrapped around it. I do not need to worry about external styles. What I would want to do at that point is remove the style. If there are multiple of course I want to remove it from all of them. If possible an example would be appreciated. Thanks</p>
        </div>

        <meta itemprop='headline' content='jQuery is string styled'>
          <meta itemprop='keywords' content='jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Martyr2'><span itemprop='name'>Martyr2</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/jquery-is-string-styled/376419">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-10-16T22:59:36Z' class='post-time'>
                October 16, 2021, 10:59pm
              </time>
              <meta itemprop='dateModified' content='2021-10-16T22:59:36Z'>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>You can use <code>:contains()</code> or better use <code>.filter()</code>. Check out this stackoverflow article which will help you out. Essentially you search a parent element for the text you are looking for (make sure to search its children elements) and if you find it, then you can grab its parent element which will be the <code>&lt;em&gt;, &lt;strong&gt; or &lt;span&gt;</code> enclosing tags.</p>
<aside class="onebox stackexchange" data-onebox-src="https://stackoverflow.com/questions/7321896/jquery-find-element-by-text">
  <header class="source">

      <a href="https://stackoverflow.com/questions/7321896/jquery-find-element-by-text" target="_blank" rel="noopener nofollow ugc">stackoverflow.com</a>
  </header>

  <article class="onebox-body">
      <a href="https://stackoverflow.com/users/504612/sisko" target="_blank" rel="noopener nofollow ugc">
    <img alt="sisko" src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/9/89761db411c4afed393e511f33621eb7ec8ff452.png" class="thumbnail onebox-avatar" width="256" height="256">
  </a>

<h4>
  <a href="https://stackoverflow.com/questions/7321896/jquery-find-element-by-text" target="_blank" rel="noopener nofollow ugc">jQuery: find element by text</a>
</h4>

<div class="tags">
  <strong>jquery, text, find</strong>
</div>

<div class="date">
  asked by
  
  <a href="https://stackoverflow.com/users/504612/sisko" target="_blank" rel="noopener nofollow ugc">
    sisko
  </a>
  on <a href="https://stackoverflow.com/questions/7321896/jquery-find-element-by-text" target="_blank" rel="noopener nofollow ugc">02:54PM - 06 Sep 11 UTC</a>
</div>

  </article>

  <div class="onebox-metadata">
    
    
  </div>

  <div style="clear: both"></div>
</aside>

<p>Edit: As for the stripping of the tags, maybe this article can help…</p>
<aside class="onebox allowlistedgeneric" data-onebox-src="https://www.sitepoint.com/jquery-strip-html-tags-div/">
  <header class="source">
      <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/4/a/4a24774c44c34058048c837d8beb541eec2667f7.png" class="site-icon" width="32" height="32">

      <a href="https://www.sitepoint.com/jquery-strip-html-tags-div/" target="_blank" rel="noopener">sitepoint.com</a>
  </header>

  <article class="onebox-body">
    

<h3><a href="https://www.sitepoint.com/jquery-strip-html-tags-div/" target="_blank" rel="noopener">jQuery Strip All HTML Tags From a Div - SitePoint</a></h3>

  <p>Simple jQuery code snippet to strip all html tags from a div (ie keep only the text from inside the html tags) using the jQuery replace() function.</p>


  </article>

  <div class="onebox-metadata">
    
    
  </div>

  <div style="clear: both"></div>
</aside>

<p>Adjust to the tags you want to strip of course.</p>
        </div>

        <meta itemprop='headline' content='jQuery is string styled'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/philhagen'><span itemprop='name'>philhagen</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/jquery-is-string-styled/376419">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2021-10-20T16:37:37Z' class='post-time'>
                October 20, 2021,  4:37pm
              </time>
              <meta itemprop='dateModified' content='2021-10-20T16:37:37Z'>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hey, this is exactly what I was looking for. Right now a little rusty with jQuery but I plan to get up to speed. Super help my friend. Thank You <img src="https://emoji.discourse-cdn.com/apple/smiley.png?v=10" title=":smiley:" class="emoji" alt=":smiley:"></p>
        </div>

        <meta itemprop='headline' content='jQuery is string styled'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02585cd527e34d477c5ad76e529b1fc22a488f1b.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/system'><span itemprop='name'>system</span></a>
            
              closed 
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/jquery-is-string-styled/376419">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2022-01-19T23:38:02Z' class='post-time'>
                January 19, 2022, 11:38pm
              </time>
              <meta itemprop='dateModified' content='2022-01-19T23:38:02Z'>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.</p>
        </div>

        <meta itemprop='headline' content='jQuery is string styled'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <div id="footer-ad-spacer"></div>
<div id="footer-ad" class="proper-ad-unit ad-sticky">

    
     <div id="proper-ad-sitepoint_left_sticky">  </div>
     
</div><script src="https://sea2.discourse-cdn.com/sitepoint/community/theme-javascripts/be63710d6fb6a95a92f8c7ea8836704b560e4661.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
