jQuery and SWFObject slideshows not working in IE9

I am using some jQuery and SWFObject slideshow modules on a website and while they work fine in Firefox, in IE all the images line up one under the other down the page. I managed to fix IE7 by enabling Active x stuff in Internet Options/Security/Custom Level but although I have done the same for IE9, the issue remains.

It is just on my computers running IE9 that this is happening luckily for my clients. I have used other jQuery scripts on other sites and they work OK in IE 7 and 8.

Are there any other settings that I need to address?

I am wondering if it is because there is no Adobe Flash Player yet (except a beta) for IE9 on Windows 64 bit?

You shouldn’t need to alter any settings on the browser if it has normal settings. I’d avoid the jquery implementation of swfobject and just use regular swfobject as the jquery version has bugs.

Yes, that’s what I thought - about the browser.

Sorry, l should have made clear it is the SWFObject that is the problem. The slideshows (JQuery) are OK. The slides in the SWFObject (which has no thumbnails) which are supposed to play automatically like slideshow with pan and zoom are the ones that are just all seen at once on the page in a vertical row.

This is happening on more than one site. For example, Home

It seems to be just on my computer when I check it in IE9. MY laptop has IE7 and its fine.

If you are seeing all the images in a row, then what you are likely seeing has nothing to do with flash at all - what you are seeing will be the alternative content, that has neither been replaced by swfobject, or processed by jquery, which would indicate javascript is switched off on internet explorer on that PC

I know it has to be something on this particular computer, but I have already gone into Internet Options/Security - Custom Level and anything to do with srcipting is either enabled or prompt; also Internet Options/Programs/Manage Addons and Java is enabled so am at a loss as to what to check next.

Is there anything specific that you can suggest I check?


Just as an experiment, I disabled all JS in FX and yes, it displayed all the images as in IE9. I’ll try re-setting IE settings.
Yes, that did it. All good now.

Thanks for the explanation!