Is this a bug for phpmyadmin?

I have a users table with several records in it, but when I click the table,

the browse button is disabled.
But I know there are some records in it cause when I “Browse Distinct values”, you can see quite a few,

why does the browse tab not work?


Looks like a bug. Anyway, even if this disabling of the browse button works correctly this behaviour (or a “feature”) always irritated me because while there may have been no records when the page was displayed doesn’t mean there are no records now. This button disabling is just stupid.

These screenshots remind me of old days - I realize I haven’t used phpmyadmin for such a long time and I don’t miss it at all. There are many much nicer alternatives. Occasionally, I only see how bloated and slow phpmyadmin is becoming with each version - as the devs are adding heavy ajax stuff and all kinds of useless bells and whistles.

what is better?

I too have moved away from using phpMyAdmin.

I tried MySQL Workbench for a while

But now I prefer working with the mysqld CLI

I find MySQL Workbench a bit clumsy for most database operations but sometimes I use it for visual database designing - it’s EER diagrams are quite nice.

Most most database stuff I use Heidi SQL - very convenient although sometimes it has a tendency to crash - this needs getting used to. Recently I’ve tried DBeaver - also quite nice and advanced database editor.

For most simple management through a web browser I use Adminer. Easy, fast and no bloat.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.