Interesting problem with site restoration?!

I have been trying to help a friend restore his clients site after the client somehow broke it. I have reinstalled wordpress sites from backups quite a few times. He was using a backup plugin that kept numerous file and database backups. We tried a few different dates all the way back to the same day that I passed the site over to him. I deleted all the files, uploaded and unzipped the file backup. Then I dumped the database and restored that from the database backup of the same corresponding day. Refreshed the site, everything was perfect! However, refresh again, and it was back to being messed up. I tried clearing my browser cache too. He had a cache plugin on the site that I believed may have caused the problem, although the cache in the backup shouldnt have had the mess ups in it, but after restore I would delete the plugin and related files from cpanel before testing the site. Nothing seems to work. What really baffles me is that it appears to be fixed until a second refresh. Can anyone shed some insight into this?

Update on this issue: I realized today that the site stays correct even on refresh, until you log into the dashboard. Once you view from dash its back to being messed up.