Input Box Size issue with IE

Input Box Size issue with IE. I created HTML and same HTML working fine. When I put same HTML in VF component it’s working fine for Firefox & Chrome but for IE, text feedback box size shrinking too much.

<apex:outputPanel styleClass="popup" layout="block">
                          <a href="#" onclick="ResetFeedbackForm('feedbackPopup');"><img src="{!URLFOR($Resource.Wirestone,'Images/Tile_Images/CP3_X.png')}" style="float:right;"/></a>
                          <table width="100%" height="100%">
                            <tr><td colspan="2" align="center"><apex:outputLabel styleclass="page-title">{!SubmitFeedbackLabel}</apex:outputLabel></td></tr>
                           <tr height="100%"><td colspan="2"><textarea id="feedbackText" onkeyup="ToggleFeedbackSubmit()" onmousemove="ToggleFeedbackSubmit()" class="textfeedback" /></td></tr>                          
                           <tr><td>&nbsp;</td><td/></tr>
                           <tr>
                                <td align="center"><input type="button" id="feedbackSubmit" value="{!submitLabel}" class="btn-gray btn-gray-small text-gray" disabled="true" onclick="SubmitFeedback()"/></td>
                                <td align="center"><input type="button" id="feedbackSubmit" value="{!cancelLabel}" class="btn-gray btn-gray-small text-white" onclick="ResetFeedbackForm('feedbackPopup')"/></td>
                            </tr>    
                          </table>
                        </apex:outputPanel>

CSS

.textfeedback
{
    width:100%;
    height:100%;
    margin-bottom: 10px;
    resize:none;
    

}

There isn’t enough code to tell how the page should work, but I’ll hazard a wild guess that the HTML might have something to do with whatever is wrong.


                          <table width="100%" height="100%">
                            <tr><td colspan="2" align="center"><apex:outputLabel styleclass="page-title">{!SubmitFeedbackLabel}</apex:outputLabel></td></tr>
                           <tr height="100%"><td colspan="2"><textarea id="feedbackText" onkeyup="ToggleFeedbackSubmit()" onmousemove="ToggleFeedbackSubmit()" class="textfeedback" /></td></tr>                          
                           [color=red]<tr><td>&nbsp;</td><td/></tr>[/color]
                           <tr>
                                <td align="center"><input type="button" id="feedbackSubmit" value="{!submitLabel}" class="btn-gray btn-gray-small text-gray" disabled="true" onclick="SubmitFeedback()"/></td>
                                <td align="center"><input type="button" id="feedbackSubmit" value="{!cancelLabel}" class="btn-gray btn-gray-small text-white" onclick="ResetFeedbackForm('feedbackPopup')"/></td>
                            </tr>    
                          </table>

From your code, the RED row has a stray <td/> thingy, and is either missing the colspan=“2” attribute or it is missing another <td></td> pair.

ITT, is there a message?